.SQL Textfile


#1

Hi I was wondering if anybody knows the problem to this. Everytime no matter what script I try to install using PHP MyAdmin, I can never successfully load tables using any .sql textfile that comes with the script, I get so many errors like for example:

Warning: Unable to create ‘./tmp/phpRQqgzE’: No such file or directory in /usr/local/dh/web/phpmyadmin/read_dump.php on line 259

Warning: Unable to move ‘/tmp/phpRQqgzE’ to ‘./tmp/phpRQqgzE’ in /usr/local/dh/web/phpmyadmin/read_dump.php on line 259

Warning: fopen("./tmp/phpRQqgzE", “r”) - No such file or directory in /usr/local/dh/web/phpmyadmin/read_dump.php on line 261

Warning: stat failed for ./tmp/phpRQqgzE (errno=2 - No such file or directory) in /usr/local/dh/web/phpmyadmin/read_dump.php on line 261

Warning: fread(): supplied argument is not a valid File-Handle resource in /usr/local/dh/web/phpmyadmin/read_dump.php on line 261

Warning: unlink() failed (No such file or directory) in /usr/local/dh/web/phpmyadmin/read_dump.php on line 262

Etc.

Now if the script comes with a installation.php file and I run it from the browser I seem to never have any problems once or ever, the tables are created just fine. So basically my question is why cant I create the tables manually using a .sql textfile in PHP MyAdmin ever? Is there a way around this.

Thnx
MoRph
www.dismorphic.com


#2

I ran into this about 5 seconds ago and came right over looking for an answer.

I believe Dreamhost has a problem. I’m gonna go through support and report it. I guess I’ll search out that how-to from the command line crap, grrrr.

[color=#0000CC]jason[/color]


#3

If you have shell access, you can try doing it from the command line using:

mysql -h[hostname] -u[username] -p[password] [database] < backup-file.sql Replace […] with the appropiate values, eg

mysql -hdatabase.domain.com -usomeuser -psomepassword the_database < install_database.sql The error messages indicate phpMyAdmin is not able to create a temporary file to recieve the .sql textfile you are uploading.

Laterz


#4

Just letting everybody know this bug should be fixed now!

josh!