Special characters in urls

design

#1

I’ll admit it’s my fault for using parentheses in a filename, but the damage has been done. With my previous host, the server handled such files ok.

Here’s one of those files:
http://takethu.com/albums/artsy/stitched/thumb_Stanford_-night_2003-03(2).jpg

With DreamHost, the converted version of that url gives a 404 error. Apparently, the forum software here converts the % code of the characters. Pretend that the right and left parentheses are displayed as % 28 and % 29, respectively, but remove the space between the % and numbers due to the software decoding what I entered.
http://takethu.com/albums/artsy/stitched/thumb_Stanford_-night_2003-03(2).jpg

However, the file loads fine with my previous host’s server:
http://galaxy.lunarpages.com/~tu20002/takethu/albums/artsy/stitched/thumb_Stanford_-night_2003-03(2).jpg

Is there something I need to put in .htaccess to make the urls recognized the way they were before?

If context helps, this is the page on which the image file shows up (or is supposed to):
http://takethu.com/index.php?cat=32

At that url, you could see the url that I referred to in the source.

The above observations are based on using Firefox. In IE, it is able to handle the problematic url and the image shows up fine on the page.

Thank you.


Thu


#2

you mean ) changes to ( and ( changes to )? if so, that’s backward and probably your problem.

i went to http://takethu.com/albums/artsy/stitched/thumb_Stanford_-night_2003-03(2).jpg in firefox and it worked fine for me…

track7 - my dream-hosted site


#3

Sorry for the mix-up. There’s no backward issue. I should have said left and right, not right and left. :slight_smile:

Now the problematic url works fine on my work computer with Firefox, and the previously missing image on the gallery page shows up.

I’ll have to see if there’s a version difference that is affecting Firefox’s display of the url. The thing is that it works fine with my previous host’s server.

Thanks for looking into it and letting me know that the url works for you.


Thu


#4

Check also your “view” setting in Firefox and go down to “character encoding”. I use Firefox for going to secure sites as they load about 10X faster with it than with IE7. However, there are differences in their behavior, look, and feel.

Cheers!
Vern
http://vernsdidj.com didgeridoo info and more