Spamhaus error

I am unable to send email through outlook express, everytime my mail block by spamhaus by this error. “The message could not be sent because one of the recipients was rejected by the server. The rejected e-mail address was… ’ Protocol: SMTP, Server Response: ‘554 Service unavailable; Client host [] blocked using xbl.dnsbl;’, Port: 587, Secure(SSL): No, Server Error: 554, Error Number: 0x800CCC79”

How can i get rid of this or i should bypass spamhaus.
i tried both PORT 25 and 587, but still same problem.

pls solve it soon.

It would seem that your IP address (or possibly your Internet Service Provider) is being blocked by Spamhaus. So ya, you could either contact them and ask them to remove you from their blacklist, or just bypass using them if possible.

how to bypass. i am a beginner, how can i bypass, bcoz mostly ip are blacklisted and i m using DSL assign everytime Dyanamic IP.

Pls tell me how to bypass this.

Mousee has it right, but there is another “quick and dirty” workaround also. Just terminate your connection to your ISP, wait a bit, and re-connect. As that IP address is indicated to be a “dynamic” address, when you re-connect you should be issued another - if Spamhaus has not blocked the whole range of IP addresses, (or at least your new one), the problem will go away (at least till they block it again :open_mouth: )


I will try it many times but all times, it’s blocked by spamhaus. tell me there is anyway to bypass this or what should i do ?

I’d suggest contacting your DSL provider and complaining loudly…they need to get on the ball and talk with Spamhaus to try and resolve it…though that is sometimes a lot easier said than done. :wink:

You can’t really “bypass” Spamhaus…it’s the receiving system that chooses to reject mail from IP addresses on Spamhaus’s lists and, since you are at the mercy of your dynamically assigned IP address, it’s a bit of a crapshoot.


Since that’s the case, as rlparker suggested, you’ll need to either contact your ISP or spamhaus and ask them to remove you.

There isn’t really anything more you can do (that I’m aware of), other than possibly use a proxy, which isn’t secure at all and thus I can’t help you with that.
You could however always send your emails out through DreamHost’s webmail service though - I don’t believe that will get blocked by spamhaus.

Quick notes:

  1. As an individual user, neither Spamhaus or the CBL will remove an individual IP. And seeing as the IP you listed here is a dynamic IP from, chances are it’s in the CBL and/or NJABL and won’t be removed even by request from your ISP.
  2. You should be sending email from your domain’s MX server anyway - so prior suggestions about using your DH mailserver to send mail are pretty much your only recourse.
  3. If you value your hosting services here, be VERY sure what you’re sending through DH’s mailserver is NOT spammy in any way.

Your point #1 is not entirely correct. While I agree Spamhaus will not generally remove an individual’s IP, as they seem to typically consider mail sent from a residential zone to be blacklisted (dynamic blocks especially), they do offer a method of seeing why you are blacklisted and give you the opportunity to attempt to remove it on the main page of their website.
One example would be here

Long ago, when I didn’t own a real domain name (I used’s services), I found myself blacklisted through spamhaus because I was under a residential block. I used a similar form to that above (it was slightly different) and was able to be un-blacklisted. Unfortunately it applied only to that IP. So when my IP changed, I had to send the request again.

Anyways, I’m not sure if their policy in that regards has changed recently or not, but it’s still at least worth trying once :wink:

Your last post got me to thinking, so I did a little further research on the original poster’s IP address. Interestingly enough:

"Ref: PBL115295 is listed on the Policy Block List (PBL)

Outbound Email Policy of The Spamhaus Project for this IP range:

This IP range has been identified by Spamhaus as not meeting our policy for IPs which should deliver ‘direct-to-mx’ mail to PBL users.

[color=#CC0000]Important: If you are using any normal email software such as Outlook, Entourage, Thunderbird, Apple Mail, and you are being blocked by this Spamhaus PBL listing when you try to send email, the reason is simply that you need to turn on “SMTP Authentication” in your email software settings (Tools : Accounts : Properties : Outgoing Mail Server : check “My server requires authentication”).
If you do not know how to do this, ask your Internet Service Provider for help with “SMTP Authentication”.[/color]

that from:

I think that is probably worth a try!