SpamAssassin user_prefs not working?

apps

#1

I thought I could tweak the SpamAssassin behavior by editing my user_prefs file (created in the ~/.spamassassin directory) however it doesn’t appear to work. To test I added:

add_header all Test yes

which should add the header/value

X-Spam-Test: yes

to all my email. But it didn’t.

Isn’t user_prefs supposed to work???


#2

This could be caused by the DH mail servers having an older version of SpamAssassin than the other servers; I don’t think v2.20 supported those config file settings. See if you can make a config file compatible with v2.20.


#3

Thanks for the tip - I checked out the current SA docs on my machine and it seems to have the same syntax that I tried.

However I did read something new about user_prefs which says there’s a config var allow_user_rules that defaults to false. This is apparently for security and would preclude me having any rules in my user_prefs file :frowning:


#4

You can get around this by installing a copy of SpamAssassin in your account. Check the Wiki for instructions.