SpamAssassin 2.63

apps

#1

I have tried 3 times to install SA using these instructions. These instructions have worked for an aquaintance of mine, but they will not work for me. I even gave my friend shell access so he could look around and he reported that everything was in the right place. Can anyone offer any suggestions as to what I might try to get SA working?

Peace,
Matt

cheapo.cc


#2

How do you know it’s not working? What are the error messages? On what system are you trying to install this software?

A little more detail will allow us to help you better.

  • wil

#3

Thanks for your reply.
I am the original poster.
(I forgot to log-in.)

I am trying to install SA on Dreamhost. My server is Schnapps.

I don’t think it’s working because:
a) spam is not being moved to the spam folder
b) no SpamAssassin info appears in my mail headers.

If there is anything else I should tell you, please let me know!

cheapo.cc


#4

Enable procmail logging and make sure messages are showing up in there, and that there aren’t any errors.

Also check the permissions on your .procmailrc and .forward.postfix files.


#5

The permissions on both my .procmailrc and forward.posfix files are set to 644. Is that correct?

and these are the contents of .promailrc:

[code]# ~/.procmailrc for Dreamhost

Uses Maildir format mail directory.

Directory for storing procmail-related files

PMDIR=$HOME/procmail

Set to yes when debugging

VERBOSE=yes

Logging

LOGFILE=$PMDIR/log

Remove # when debugging; set to no if you want minimal logging

LOGABSTRACT=all

Message directory (Courier IMAP and mutt)

MAILDIR=$HOME/Maildir

Folder names for use in recipes should be of form ‘.Foo/’ for Maildir format

INCLUDERC=$PMDIR/spam.rc

Anything that hasn’t been filtered yet is delivered to your inbox by this

recipe. The ‘/’ at end of pathname indicates a Maildir format mailbox

:0
$HOME/Maildir/[/code]How’s that look?

cheapo.cc


#6

and this the header of the most recent test e-mail I sent myself:[code]Return-Path: <matt @ example.com>
Delivered-To: [munged]@knife.dreamhost.com
Received: from mx.eastlink.ca (mx.eastlink.ca [24.222.0.20])
by knife.dreamhost.com (Postfix) with ESMTP
id 120BBE403A; Fri, 30 Jan 2004 11:23:01 -0800 (PST)
Received: from PC4156 ([24.222.163.149])
by mx1.eastlink.ca (iPlanet Messaging Server 5.2 HotFix 1.12 (built Feb 13
2003)) with ESMTP id 0HSB002BDHNHTG@mx1.eastlink.ca; Fri,
30 Jan 2004 15:18:59 -0400 (AST)
Date: Fri, 30 Jan 2004 15:20:44 -0400
From: Matt Jarsky <matt @ example.com>
Subject: test
To: [munged] @cheapo.cc
Cc: ‘Matt Jarsky’ <[munged] @cheapo.cc>
Message-id: 0HSB002BRHNNTG@mx1.eastlink.ca
Organization: Kassner Goodspeed Architects
MIME-version: 1.0
X-MIMEOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
X-Mailer: Microsoft Office Outlook, Build 11.0.5510
Content-type: text/plain; charset=US-ASCII
Content-transfer-encoding: 7BIT
Thread-index: AcPnZiZ7tVdJveKUSBeYEyVSJsAE3A==

[/code]cheapo.cc


#7

You didn’t answer my question, though (about the logfile). What are the permissions on .procmail/ (the directory), and does .procmail/log exist?

I assume that .procmail/spam.rc exists?

I would set the files to 0600, and directories to 0700, but the main thing is to make sure you don’t have any group writable directories… if ~/.procmail/ is 0775, for example, it won’t work. If the logfile doesn’t exist at all despite being mentioned in your .procmailrc, the problem is most likely related to permissions.


#8

No, there’s no logfile in the procmail folder.
I will try the permissions you suggest.

cheapo.cc


#9

See the period ‘.’ in front of ‘procmail’?
I don’t have that. (I do have spam.rc in my ‘procmail’ directory, however.)
The instructions over at webspiffy (see first post in thread), don’t have a period on the name of that directory either.
Should one be there?

Also as far as setting the permissions goes:
I am using cuteFTPpro. Setting permissions to 0600 results in ‘Group’ having read and write privileges. Is that correct? Or should it be ‘Owner’ having those privileges?

Thanks.

cheapo.cc


#10

No - just a typo on my part (I usually use .procmail, but you can use procmail or anything else you want).


#11

What about the permissions?
You are using four digit permissions, but CuteFTPpro only accepts the first three digits. Should I leave off the leading zeros?

cheapo.cc


#12

It doesn’t matter - just omit the first digit (or do it from the command line)
0755 is the same as 755.


#13

ps - I fixed it for you. Your permissions were reversed (you had 060 / 070 instead of 0600 / 0700).

It’s working now.


#14

Thank-you wil.
I see that SA is now generating a log, but I still don’t see any SA information in the headers of incoming mail. My understanding was that some SA information would show up in the header.

Er, also, I just received a piece of lottery spam.

cheapo.cc


#15

It showed up for me when I sent a test message.

X-Spam-Checker-Version: SpamAssassin 2.63 (2004-01-11) on spork.dreamhost.com
X-Spam-Status: No, hits=0.0 required=7.5 tests=none autolearn=ham version=2.63
X-Spam-Level:


#16

hmmm…

I have e-mail notification turned on for this thread, so when you replied, I was notified by e-mail. Here is the header from that message:

Return-Path: <xxxxxx@monkichi.sd.dreamhost.com> Delivered-To: m5596279@knife.dreamhost.com Received: from monkichi.sd.dreamhost.com (monkichi.sd.dreamhost.com [66.33.206.15]) by knife.dreamhost.com (Postfix) with ESMTP id BC53DE402A for <xxxxx@cheapo.xx>; Mon, 2 Feb 2004 12:19:12 -0800 (PST) Received: by monkichi.sd.dreamhost.com (Postfix, from userid 999) id A7D3B9A263; Mon, 2 Feb 2004 12:19:12 -0800 (PST) To: xxxxxxx@cheapo.xxx From: support@dreamhost.com X-Mailer: Mailer::1.0 (http://www.gossamer-threads.com/scripts/) Subject: Reply to your post Message-Id: <20040202201912.A7D3B9A263@monkichi.sd.dreamhost.com> Date: Mon, 2 Feb 2004 12:19:12 -0800 (PST)
and here’s the bottom of the log file:procmail: Assigning "LOGABSTRACT=all" procmail: Assigning "MAILDIR=/home/cheapo/Maildir" procmail: Assigning "INCLUDERC=/home/cheapo/procmail/spam.rc" procmail: Executing "/home/cheapo/sausr/local/bin/spamassassin" procmail: [32531] Mon Feb 2 12:18:11 2004 procmail: No match on "^X-Spam-Status: Yes" procmail: Assigning "LASTFOLDER=/home/cheapo/Maildir/new/1075753091.32531_0.spork" procmail: Notified comsat: "cheapo@0:/home/cheapo/Maildir/new/1075753091.32531_0.spork" From root@schnapps.dreamhost.com Mon Feb 2 12:18:09 2004 Folder: /home/cheapo/Maildir/new/1075753091.32531_0.spork 1088 Let me say it one more time: Thanks for all the help wil.

cheapo.cc


#17

BTW - I wouldn’t post these addresses unmunged to the forum - you’ll start getting spam to them.

Notice this?
Delivered-To: m5596279 at knife.dreamhost.com

This is sent to an address which goes to a mail-only user. I believe this is pointed out in the procmail section of the kbase, but you can’t setup procmail for mail-only users. You can only setup SA for a “real” user, so you need to forward this address the the user that SA was setup under.


#18

Wow, this is getting complicated.

I have a bunch of addresses all set up as aliases of m5596279.

In the ‘Mailboxes’ panel of https://panel.dreamhost.com there is one mailbox that shows the total disk usage for my account. Is that the account I have to use?

I should set up my e-mail to check that account and set the others as aliases of the main account?

cheapo.cc


#19

Well you’d have to use the mail user corresponding to an existing ftp / shell user in order to filter that user’s mail using SA, or to do other custom procmail filters beyond what you can do from our web panel / mailboxes.example.com.

You can add additional shell / ftp users if you need multiple users to have this functionality.

Physical users and email addresses are completely separate.


#20

Will,
Thank-you very much for all your help.
I have created the necessary user account and reinstalled SpamAssassin. (And corrected the permissions again.) All is working as it should.

Peace,
Matt

cheapo.cc