Some help on a "debugging"


#1

i had a guy write some scripts. i had to fire him for various reasons.>> after<<< i eliminated him as a “user” the primary work he had done stopped working.
i now get the following msg:
Warning: require_once(/home/.ishkabibble/jandbdan/classifier.makemoneyathomeadnetwork.com/Lib/SmartyPaginate.php) [function.require-once]: failed to open stream: No such file or directory in /home/jandbdan/classifier.makemoneyathomeadnetwork.com/Lib/Smarty.php on line 93

Fatal error: require_once() [function.require]: Failed opening required ‘/domain/Lib/SmartyPaginate.php’ (include_path=’.:/usr/local/php5/lib/php:/usr/local/lib/php:Lib/’) in /home/user/dimain/Lib/Smarty.php on line 93
said files are in fact there in the directory as addressed: smarty.php, and martypaginate.php
but i have no idea at alll what the error msg is telling me or what to do to fix it.
any and all help written as if talking to a compleat idiot will be welcomed… after several hours of web search for this phrase, i can get nothing that makes sense…


#2

Go through the scripts and delete the .ishkabibble/ part. The dot thingie (forgot the name) is extraneous and can cause problems.

The second one has /domain/Lib at the beginning of the path when it should probably look more like the other paths you listed. But I may be wrong on this one.

Check the permissions on those files. They should be readable by everybody (user/group/other).

-Scott


#3

first my verry serious thanx for getting some real help to me. from your suggestion i was able to get some start made…and have now hit the next wall on this sabotaged code. didn’t want to bother anyone til i had to…
the nextr trouble i am seeing is that it appears i should be getting some pages, like, sign up or login generated by the db operating this. the page source shows “hot” words referring to other pages correctly, but there is a 404 error for each of them, like:
http://www.sub.domain.com/user/join
http://www.sub.domain.com/user/login
http://www.sub.domain.com/postingspace

in the files uploaded to the server, there is no directory “user” .which leads me to think the db is sposed to generate it.
again… this set of scripts all worked up til the day i fired the programmer, and stupidly enuff removed his ftp/ access >>after<<i fired him.
any ideas on where to look next?
and…thanx again.


#4

Quite often. there’s a .htaccess (hidden file) that makes ugly ULRs look pretty. An ugly URL is like the URL for this forum with the question marks and such.

I’m at work now, but before I forget, go to the panel and try a Restore of the domain. Under Manage Domains, the far right column is a Restore option. Pick “Oldest” since that seems to be when things worked. And pick first Restore to TIMESTAMP option and do the restore. Hopefully you’ll discover what got changed.

-Scott


#5

thanx again… an excellent idea that did >nott< work…
did the backup restore…no change…
the idea did cause me to look at the db, where i see nothing that seems to me to be able to get a page going…

one thing i did notice is that there was a “feature” when things worked in which 404 etc should have generated a page from an “excuse” list (dumb stuff like “not enuff ether in the cables”), which list is still in the db…but which does not generate the response.i got a plain vanilla 404 for stuff like “login”–even tho the page source appears to be correct so far as the html looks for a hyperlink.
could there be some chmod issue somewhere? if so…any clues?

and…thank you.


#6

If you picked the first restore option, the restored backup didn’t go live; it was just placed in your home directory to pick through. The second option makes the restore go live and renames your live site with a TIMESTAMP.

Start looking through your log files in the /logs directory. access.log has the best info. Do you have a .htaccess file hidden in your domain’s root directory?

-Scott


#7

i picked the 2nd option…for the “switch”…what occured was a new directory got created with the time stamp
using panel web2ftp to open that folder, and thn “view” the index page, i get taken to
http://sub.dimain name.com_20090826/
with a msg of cannot connect to server…
i was able to learn what editor was used by the coder, downloaded that program and used it to search the entire ap…and found no instance of .hta using th editor… and can find no .hta looking at the server from panel.
i just looked at the access.log …which means nothing to me other than it seems to be saying it tried to load itself as i checked the page…13 instances of “get”