[Solved] vps xmod_xsendfile

apps

#1

How would i install it onto the vps correctly?

I’ve used: sudo apt-get install ndn-apache22-modxsendfile
And it says it installs, but when i put this into the .htaccess file of my website: “XSendFile On” AND “XSendFileAllowAbove On”

I get an internal 500 server error.

[Solved on my own]: Turns out i had to load the module in the other http.conf file located in pserver[numbers here] file.


#2

hello hello. I have spent a whole day of my life trying to do this.

As soon as I Load the module in httpd.conf all my domains go down, I can only assume its not right.

I assume ndn-apache22-modxsendfile should already be running and doesnt actually require a install, using “sudo apt-get install ndn-apache22-modxsendfile” causes a interrupted message:

E: dpkg was interrupted, you must manually run ‘sudo dpkg --configure -a’ to correct the problem.

The https.conf file location im using is at: sudo vi /dh/apache2/apache2-ps???/etc/httpd.conf

Im adding this line to the config:
LoadModule xsendfile_module /dh/apache2/template/lib/modules/mod_xsendfile.so

I restart my server after saving and then to my horror all my sites drop. I dont know what im doing wrong so if you get this message and have any advise it would be awesome. Thanks.


#3

Contact DreamHost support. We have a tool that’ll enable mod_xsendfile properly.