So when exactly is Rails 1.1 coming?


#1

I noticed that DreamHost was going to roll out Rails 1.1 on all the servers, but then they had problems and reverted everyone back to Rails 1.0. Indeed, when I go to my site and run “gem list”, I still see “rails (1.0.0, 0.14.3)”. Also, the installed Ruby is version 1.8.2, but I believe Rails 1.1 requires Ruby 1.8.4.

Now, I don’t actually need Rails 1.1 at the moment, but I would like to upgrade eventually. Assuming that my app is fully compatible with Rails 1.1, does that mean I can simply wait a little longer until DreamHost decides it is safe to upgrade everyone? Will the upgrade then happen automatically, or do I need to do something special? The DreamHost blog has gotten me all confused about this.


#2

I have the same question. I’m building a rails 1.1 app and would like to host it on dreamhost. Given that there is no visibility into the schedule I’m thinking about hosting it elsewhere. Can someone from DH please respond?

Thanks!


#3

Given that there is no visibility into the schedule I’m thinking about hosting it elsewhere. Can someone from DH please respond?

If it’s that important, I would send your question directly to DreamHost support. I don’t think they monitor these forums regularly.


#4

I contacted support. They said they’re going to be upgrading rails and ruby 1.8.4 this week (today is Apr 18 2006).


#5

Any updates on this? I need Rails 1.1+ as I am trying to use the acts_as_taggable plugin, and it seems to not work currently.


#6

They are rolling out Rails 1.1 this week. See http://www.dreamhoststatus.com/2006/04/21/rails-upgrade-part-deux/ for info.

You can see the current version of rails and installed gems at http://rails.dreamhosters.com.


[color=#000000]DreamHost Promo Code[/color]: [color=#CC0000]Save $50[/color] with the promo code DREAMTEAM


#7

Oooh. IE-only page! Someone is using a broken box model somewhere :s


Simon Jessey | Keystone Websites
Save $97 on yearly plans with promo code [color=#CC0000]SCJESSEY97[/color]