Hi, can anyone tell me pls how can i move files from my .snapshot folder to my domain folder - im trying MV command in the console, but it says - permission denied. and what syntaxis should i use? mv folder /home/username/ or smth else? tnx


Use ‘cp’ instead. ‘mv’ implies that you’re removing the file from the snapshot, whereas ‘cp’ just makes a copy. If it’s a directory, it’s a bit more tricky. I’d use tar like this:




tnx Scott, ill remember that, i solved the problem by downloading/uploading files with ftp client =) took longer but worked perfectly as always =))


Just connect to your domain twice with the same client… I used flashFXP and you can just transfer them from the .snapshot into your curent dir… takes a couple of minutes that way.



I also use FlashFXP for retrieving files out of the .snapshot directory, as it is fast and convenient.

I also use FlashFXP for site to site transfers of large files and it is very fast, as the transfer is direct, not relying on my relatively slow home internet connection.

One thing; The .snapshot directory will not be shown in the file/directory listing of FlashFXP, even if you enable the display of hidden files. You need to manually enter the path to the .snapshot directory.


Save [color=#CC0000]$50[/color] on DreamHost hosting using promo code [color=#CC0000]SAVEMONEY[/color] ( Click for promo code details )


If you’re just moving files back to your domain, presumably to over write a mistake you made, what is the point of using tar?

What I’ve always done in the past is just to use the cp command.
log in via ssh
move into the .snapshot whatnot so you are ‘above’ the direcotry or files you want to copy. If you type ls you’ll get a direcotry listing - you should see what you want to copy. Now,
cp -f file.html /home/user/
cp -rf /home/user/

just an FYI, for your protection the .snapshot direcotry isn’t wiriteable by you, so you can’t mess up your backups. :slight_smile: That’s a good thing for the best of us some days.

–Matttail - personal website


You can’t ‘cp’ a directory, which is why one would have to use the tar/untar approach.



You can’t ‘cp’ a directory

$ cp --help | grep recursive -R, -r, --recursive copy directories recursively

If you want useful replies, ask smart questions.


Learn something new every day. Something must have changed in the last 13 years since I first tried copying a directory.