SMTP Port 587


I tried to set up my e-mail so my dreamhost mail server could be the outgoing server using the instructions described in the wiki article titled SMTP Port 587. But it doesn’t work, I only get errors when I try to send outgoing mail. I tried typing;; and, but nothing worked. I could continue to use my ISP as the outgoing mail server, but it gives me errors when I try to send as well. It will send the mail, though. Using my dreamhost mail server won’t work at all. Any ideas? Am I missing a step?


I know how frustrating that can be! There are several things that could be causing a problem besides the SMTP port, so it sometimes helps to work through each of the potential problems. To that end, and in the interests of “first things first”, are you able to send, and receive, mail via If not, you email account is just not setup completely yet (it sometimes takes as much as a full day for a new email account to go “live”). If you can send and receive via webmail, then it’s time to move on to other possible issues. [winkl]

The correct entry for your email server (POP3, IMAP, and SMTP) is “mail.yourdomain.tld”.

You could be missing a step, though it’s hard for us to tell without more information. It would help to know what operating system and email client you are using, and your ISP may also be relevant.



Thanks. Weirdly, now my e-mail is not glitching using the ISP (Comcast) Wonder if they are spying on me?

The mail.mydomain.tld did not work at all.

I am on Windows XP (2002) with Outlook Express 6.

I am receiving using and currently sending out using It is working for now, but given it’s error-ridden past, I’d just as soon send out using my domain if possible if that will be more solid. But for now I can’t get that to work at all, so I guess I’ll stick with the comcast smtp for outgoing mail.

Thanks for your help. Let me know if there is anything else I should know about or try.



Well, with Comcast you never really know what is going on part of the time, and if you are having sporadic problems even with them, you may be having (hopefully temporary) connectivity issues. :wink: .

There is another wiki page that I think you should work through:

That is a pretty good guide, and takes you step-by-stpe, so you might be able to find a “missed step” by reviewing that page. Note you will need to use port 587. Note that “mail.mydomain.tld” means “mail”+".+“yourdomainname”+"."+“Your Top Level Domain” (.com, .net, .org, etc) and not actually “tld” :wink: . I suspect you know that, but from reading your reply I just wanted to clarify that.

Also, make sure you do check the “My Server Requires Authentication” box on the “Servers Tab” (last picture) and that you DO NOT have the “Log On Using Secure Password Authentication” box checked, in either the “wizard” or the “Server Tab” of “Properties” (same screen as the one previously mentioned.)

If you follow those steps, and watch out for those potential “gotchas”, you should be up and running soon.

Good Luck!



The authentication checkbox is probably the most critical. Make sure you use your WHOLE email address me@mydomain.tld to do the login.

I have no troubles from comcast on port 25 so I don’t use 587 (yet)

Wholly - Use promo code WhollyMindless for full 97$ credit. Let me know if you want something else!


AH! Thanks for sharing that! There is a statement in the wiki that at least some comcast customers have had to use it, but it is nice to know that is apparently not an absolute.