SMF Forum: Can't Login From Front Page


#1

Hello, all!

We’re running SMF 2.0.14 and recently I’ve learned when some of our users try to login through the front page, they get the error message:

Your session timed out while posting. Please go back and try again.

However, when they are redirected to the /index.php?action=login page, they can log in just fine. This has been baffling me for weeks and I can’t seem to find anything like this posted anywhere else. Does anyone have any sort of help? Please?

Thank you so much!


#2

What’s the URL of your forums? Maybe we can try with different browsers, empty cache, etc and start isolating the issue.

Do all users have the same issue or is limited to some? Without being familiar with SMF, I’d suggest also to look at the server and application logs to see if there is anything useful there.


#3

Thanks for the response! The site is:
http://anima adoption agency.com/forum
(remove the spaces)

I’ve had 4 users speak up about the issue thus far. They’ve been using Firefox and Chrome. I’ve had two of them trying to help my troubleshoot from time to time as I cannot replicate the issue on any of my browsers.

They’ve both cleared their cache a few times and, again, can log in just fine from the secondary page! I’ve tried checking the forum logs, but I can’t seem to find a set of error messages that fit the issue. For example, I looked at the logs, then had one of the users try to log in, they received the error and I got no new errors listed in my logs.


#4

I wish I had a clue of what’s going on with those 4 users, sorry :slight_smile: If the issue cannot be replicated, it’s very hard to diagnose and solve issues.

On the other hand, I have found other problems on your site … feel free to ignore the rest of this post :slight_smile:

Your site doesn’t use SSL which these days is very bad practice. A Let’s Encrypt certificate is free, there is no excuse not to have one. If your site is hosted on DreamHost, a LE cert is free and very easy to get.

Also, I tried signing up and the captcha doesn’t seem to load:

But hitting ‘Register’ without entering anything brings me to [http://www.animaadoptionagency.com/forum/index.php?action=forum] with no error message… not sure what is supposed to happen next.

When I try to login, I get ‘the username doesn’t exist’.


#5

Thank you so much for looking it over! I’ve not had any complaints about the captcha, so… I’ll definitely be poking at that! And SSL is new to me as well! Thank you for the link! I’ll be going into those asap!

Thank you so much!


#6

You may also want try asking in the forum on the SMF website. They may have some more insight


#7

Come to think of it, I may of had this same issue with my SMF forum… Let me think on it for a bit, and see if I can rattle the cobwebs in my brainbox and remember how I fixed it.


#8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.