SMF and friendly URL's on DH

software development

#1

Hi
I have a problem with my SMF disscusion board.

On the old host I used a friendly URL’s option(with .html & no ?) and all external links were friendly linked.

On the DH is not working. Example;
Without Friendly URL’s: http://www.gimpuj.info/index.php?board=2.0
With: http://www.gimpuj.info/index.php/board,2.0.html

Serwer send info: “No input file specified.”

Can You help me with this? It’s a very important for me.

I’m sorry for my english :slight_smile:


#2

Looks like you haven’t set up the options for mod_rewrite. I’m not an expert on setting it up at all, so I can’t help you with that, but that is the problem by the looks of it. You will need to edit your .htaccess file.


#3

http://www.simplemachines.org/community/index.php?topic=84205.0;prev_next=next
SMF doesn’t use mod_rewrite, like the help pop up says, it needs php to be compiled as an apache module rather than running as a cgi. Check if this is the case.

DH by default uses PHP as CGI
http://wiki.dreamhost.com/index.php/KB_/Web_Programming/_CGI,PHP&Databases/_PHP#What.27s_the_difference_between_PHP-CGI_and_PHP_as_an_Apache_module.3F
There is a long explanation and also how to change to module, It may help you.

Regards


#4

Thanks! It worked!
I added this line

AddHandler application/x-httpd-php .phpto my .htaccess file and the friendly URL’s returned to life

Thanks!