Smarty Throwing 500 internal server error

software development

#1

On a script that worked about a month ago, I noticed now throws a 500 internal server error on load as noted in the header. Unfortunately it does not log the cause of this error and text can still be printed to the webpage. The normal 500 Internal Server error message does not appear in the browser and only shows up in the header.

It seems this error has to do with Smarty although I’m not sure if it is related to any of the php5.cgi upgrades going on through Dreamhost. I am running the latest version of Smarty and also whatever version of php5.cgi that Dreamhost is using. I have tried to track down the source of the error but since remote debugging is rather out of the question, has anyone else noticed this. It seems that a call to the fetch() function of Smarty is what triggers this but something else might be the cause.

Any help is greatly appreciated, this one just has me downright confused.


#2

Finally figured it out, was using a custom php5 ini file and that needed to be upgraded to reflect the 64bit changes.