Smart Thumbs

apps

#1

Hello,

I’m having troubles installing my Smart Thumbs script =>

ST directory writable directory /dh/cgi-system/php.cgi is not writable, change chmod to 777

I always get this even if i change my directory in the install file.

Can someone help me please ?

Kind Regards,
Kris


#2

Kris,

It sounds like your script is deriving the “writeable directory” by using a PHP environment variable that is pointing to the php.cgi file instead of the desired directory.

This is pretty common when running PHP-CGI, if the programmer assumed you would be running mod_php, and is generally pretty easily fixed by just changing the variable use, or hardcoding the path (which is what it sounds like you have tried to do).

Is that script Free Open Source software or is it a commercial/proprietary product?

–rlparker


#3

It’s a free script => http://www.smart-scripts.com/ but it works via an install.php which is encoded via zend.

It’s so strange when i choose my own path in the install file it stills go to the /dh/cgi-system/php.cgi dir


#4

Arguuugh! The “encoded via zend” part pretty much sucks!

I’ll bet ya anything the problematic variable is used in the zend encoded part of the install. :frowning:

Just to confirm the issue, you could try running it under mod_php (PHP version 4.4.7, I believe), as described here (make sure and read the comments for the “tip” on how to do this).

In short, create a text file named “.htaccess” in the root directory of your domain (yourdomain.tld) containing the single line:

AddHandler application/x-httpd-php .php

and try running the install again. If the problem is the suspected environment variable, this should allow it to run.

I hate zend / ioncube/ etc. encoding because it makes it hard /impossible to fix stuff like this. :wink:

IF you can confirm that this is the problem, maybe you can get the author to “fix” his code so that it does not rely on a given PHP mode.

Purely my opinion here, but this line from their website would probably queer me on using this code:

“The script will skim 1.5% of your traffic per install, if you want to remove the skim you can simply buy a key to migrate your copies to the commercial non skimming version. Small link back to our site is required.”

Hey, everyone is entitled to their own business model, but if the script “skims” traffic, who know what else it does in that encoded code?

–rlparker


#5

after adding the htaccess file it goes to this url => http://st/setup.php

so the url is incorrect now :frowning:


#6

Hey, it was worth a shot … if the install.php is encoded, my guess is it will either work, or it won’t, and I don’t know how to go about fixing it.

–rlparker


#7

can the people at dreamhost fix this ?


#8

It works now but i receive another error :slight_smile:

On
(Error) open_basedir causes rotator to only be able to write to this domain folder, thus it cant share files with your other domains.

and this =>

Warning!
PHP is enforcing memory limit '50’M and this is insufficient to run the script. Optimal value is 64M. It takes a lot of RAM to open large images and edit them. Increasing this memory limit will require editing max memory setting within php.ini from 50M to at least 64M.


#9

[quote]On
(Error) open_basedir causes rotator to only be able to write to this domain folder, thus it cant share files with your other domains.[/quote]
Are you running it with that .htaccess file? It looks as though you are, as open_basedir is “feature” of DH’s mod_php implementation. That script is looking scarier and scarier. :wink:

[quote]Warning!
PHP is enforcing memory limit '50’M and this is insufficient to run the script. Optimal value is 64M. It takes a lot of RAM to open large images and edit them. Increasing this memory limit will require editing max memory setting within php.ini from 50M to at least 64M.[/quote]
To fix that, you will have to abandon the use of mod_php, and either install your own version of PHP or use a copy of the DH PHP-CGI with a custom php.ini file. Both of these methods are allowed, but not supported, and most find it difficult to do unless you are very competent with PHP installation and the *nix shell.

Even if you succeeded with that, you are likely to run into CPU/Memory problems trying to run that on a shared server; the DreamHost procwatch program will not allow prolonged precessing activities on their webservers in order to facilitate the serving of webpages for all users on a server.

–rlparker


#10

They probably could change their software to facilitate that script, but I’m sure they won’t; it wouldn’t be a “fix” at all and could impair the security of their systems and negatively impact the other users on your server.

This script looks as though it is probably only appropriate for use on a dedicated server where only you are at risk of exploitation or the effects of heavy resource use.

DreamHost provides robust and capable shared servers for the serving of web pages and reasonable/limited related processing. This script has several characteristics that appear to me to make it unsuitable for use in such an environment.

–rlparker


#11

I have installed the script :slight_smile:

I’ve created a custom php.ini and all the problems are gone now.

Thanks for your help and also thanks to the dreamhost people !


#12

Outstanding! It’s great when a plan works out, eh? :slight_smile:

–rlparker


#13

That’s true :slight_smile:

All the stress is gone.