Slow WordPress site on VPS - Dreamhosters issue?



Hi there,

I’m working on a WordPress site for which I can’t assign the proper domain name until the site is finished. Hence I’m developing on it via a mirrored domain on (as recommended by the Dreamhost peeps in various articles).

The site is:

However, it’s REALLY slow. I’m caching with W3 Total Cache but even the cached pages take ages to load. It’s by far the worst when you first request a page after the site has been idle for a while. That first request takes tens of seconds!

Are there any performance implications of using the mirrored domain? Will things suddenly, magically speed up once I propogate the proper domain name and remove the mirroring? I can’t see how they will…

I’ve even bumped the resources up on my VPS to 500mb and it hasn’t made any difference.

I haven’t finished optimising the site at all yet - I know I’ve got quite a few JS calls going on that need to be combined, but it’s soooo slow I can’t imagine any amount of optimising will get the speed up to something I comfy with.

Anybody got any other ideas? Is it possible there’s a corruption with the setup of my VPS. The only other site I’ve got on there is a fresh WordPress install that’s not live and note even being developed on at the moment.




To answer your question, no, mirroring would not have any effect on the performance of your domain. It serves the same content from the same Apache instance on the server, so nothing could get in the way of that.

We’ve done some testing and looking around, specifically at the access.log for that domain, and a detailed email is on the way. If you find yourself needing assistance, you’ll be able to reply there directly once we’ve emailed you. :slight_smile:


I am having the same issue (It would appear) as Dave and have not been able to find any public information on a resolution.

I tried a help ticket and was informed that everything was running smoothly and site load times were between 1-2 seconds. This is about the time I get after the first load after the site is idle.

I’ve tried to see what is taking so long (with firebug on and the first load after idle takes from 6-26 seconds to even begin to download the html/css/js. The time is taken by the initial GET of “” which is in a period of waiting for all but a few moments.

This happens even when most of the site content has been locally cached. After waiting 5-10 minutes and refreshing the first GET is very slow.

Any help would be greatly appreciated.

I do hope it is ok that I tacked my issue on this post. It was the first thing to come up in a search yet doesn’t have any usable info. Maybe we can fix that.


You’re not running any caching plugins on your site, which would be my first go-to.

Have a look at a Google Page Speed diagnostic:

Basically you’ll gain a lot with minification and using expires, both of which can be done fairly painlessly. There are plugins to minify, though w3-total-cache can do it for you and cache, which wouldn’t be a bad idea.

Expires is either done via w3-total-cache, or you can manually enter it in your .htaccess.


I understand the gut reaction of “optimize your site + enable caching” but the initial speed I’m getting across the board (even when the browser has already cached the site) does seem to point to something else. is one of many, also exhibits this behavior (as do seemingly all site in my VPS) and has had some optimization done. Even without optimization 6-26 seconds is not just an awfully large load time, but also seems like a pretty big variation?

edit: Thank you for taking the time to run the diagnostic and the incredibly quick reply! I enabled W3 Total Cache on with some basic settings for now. Same issues appear but thanks for the reminder.


Hi Liopia. I experienced the same “gut reaction” from various Dreamhost staff. With the kinds of speeds your experiencing I don’t think a few small tweaks are going to cut the mustard. I mean minification of files can really only make a small difference.

I was never able to resolve the problems with this site, so I ported it across to WP Engine and it ran beautifully without requiring any of the suggested tweaks.

It seems there are definitely infrastructure issues with running certain sites on Dreamhost. It might actually be peculiar to Dreamhost VPS 'cos I’ve never had problems running WordPress sites on my Dreamhost shared account! (They’ve not been super quick - it’s shared hosting after all - but they’ve been better than WordPress on my VPS).

It’s a shame, as I’ve been with Dreamhost for years, and will continue to use them for small sites that are suitable for shared hosting. However, if you need the extra grunt that’s made you think you need a Dreamhost VPS, I think you’ll find yourself better off with a different host. For a WordPress site you’d struggle to do better than the WordPress only WP Engine or a dedicated host.




Actually, you gain most of your speed by customization of PHP (caching, messing with min/max servers etc).

Testing against a locally cached file isn’t the best comparison. Look at

That is blindingly fast, and it’s a static HTML page. Thus, the logical answer is your site needs to be optimized.


I just tested that link and it took over 50 seconds to load. I then reloaded it and it took only a second. This was the exact issue I was experiencing; and I was using W3 Total Cache.


The readme link takes a second to load for me on a fresh browser (i.e. one I’ve never used to visit it before), and I’m on a pretty slow connection. It’s even fast for Google:

I wish I could reproduce that, Deaner666, because if I was seeing that (slow static HTML and slow PHP), then I’d be pestering a hardware guy to look at the box. All the stats and checks I can run to the bridgecitybaking server tell me that the server’s running fine, but the website is rendering slow. I’m not saying DreamHost is prefect, there’s always room for improvement, but this doesn’t appear to be that case. :frowning: Be easier if it was, eh?

Now I do see 50 seconds + to load the main page of the site, and it’s pretty clear that browser caching isn’t set up to peak levels (I get slow reloads too, but again, I’m on a slow connection). Turning on GZIP and minifying the HTML will give you pretty amazing results in most cases :slight_smile: W3 Total Cache is a great plugin, if complicated, and can be a lot of trial and error to configure. I messed up my install many times before finally getting it right for my sites.


Ironic addendum to this thread…

I cancelled my Dreamhost VPS and the system automatically moved the site over to my shared hosting account (a very nice feature by the way) and it runs MUCH faster! It’s actually a perfectly reasonable speed on the shared hosting. Fast enough that I probably wouldn’t have had to move the site to WP Engine if I’d known in advance. WP Engine is still slightly faster, but not by as much as I would have expected. This is slightly unbelievable to me! And I wasn’t on the lowest tier of VPS either.


Thank you for your posts. I’m running into exactly the same issue. All of my sites were running fine until the east coast datacenter was added. Now all my sites have about a 10 sec wait time for the first http request. I switched to VPS and configured w3 cache and, if anything, it’s gotten worse!


I have the same problem except its hard to determine the exact cause since they moved my server the same day as my wordpress update…

It was not until I updated the database upon logging into the sites panel that the site became slow.
VPS/VPS Mysql.
2 sites on the server both became slow after the database update.


Thank you for letting me know, MtnXfreeride.

I really wish I knew why the response time on the initial http request takes so long. I had this same issue, with GoDaddy, around 2009 and moved all my sites over to DH in one night and everything has been good till recently.

Right now I’m looking at Dreamhost’s guide Using WordPress with W3TC and DreamObjects.


James, I don’t see that you’re on a VPS (unless it’s with an account with a different email than you use in the forums).

If you are on VPS, turn on xCache and then (I hate to say this) downgrade PHP to 5.2 to take advantage of it. You can then tell W3TC to use that for Object Caching, which will help more.

MtnXfreeride, same advice about xCache, but also try tuning your database with an optimization via phpMyAdmin. Normally, though, you don’t need a VPS for SQL unless your database is ginourmous.

You can also try using nginx instead of apache, since that can sometimes improve speed, depending on what’s dragging your server.


Hey Ipstenu,

Thanks for reaching out!

I am using a different email (sorry for the confusion). My DH email is info@ instead of jim@.

Yeah, actually I just went to 5.3 CGI (from 5.2) and I was just using xCache in the Object caching (and others) but the 10 sec delay, in the first GET request was still there. I was going to try 5.3 CGI, like the article mentioned, but I think I’m going to head back to 5.2 since XCache is supported there.

Thank for the advice. Can you think of anything (on my end) that would contribute to the long wait time?


James, thanks for the other email :wink: Now I see you.

Since you’re on a VPS, there is always the option to install another cache tool yourself. Both APC and eAccelerator are pretty awesome, and they work with PHP 5.3.

Looking at your server stats, the load is quite low (usually under .5, which is what you want to see). I mean, that’s crazy awesome :slight_smile: I have a site I struggle constantly to keep under 1. One thing that’s annoying, is after you switch to PHP 5.2, you have to edit each domain to turn on 5.2 and xcache :confused: So as soon as you’ve done that on a couple domains, you may see an improvement.

If not, it’s time to hit up sites like Google Page Speed and see if they can tell you “Aha! You’re offloading too much Javascript!” as a problem.


Ipstenu-DH, why should a downgrade even be needed? All we have done is get our wordpress installs updated… I dont even think wordpress is really the problem. I think ive narrowed the issue down to mysql being the issue. I have another site which uses Mysql and its slow as my wordpress now at connecting suddenly… nothing has changed on that site in 7-8 months… but any page without a mysql connection is instant.

Im thinking this is a data center moving issue, and i hope it gets acknowledged as an issue.


MtnXfreeride - The only, only only, reason I ever even consider suggesting PHP 5.2 is if you want xCache and don’t feel up to installing server side caching on your own. Generally? You’re right, 5.3 is way better and way less memory intensive. I advocate it all the time.

And as for the downgrade in SQL… Well. This is weird to say, but I’ve seen VPS SQL run slower than shared in some cases. This is a universal thing, by the way, not DreamHost alone. My working theory is that it’s like getting glasses that are too strong: they make your eyes tired faster.

Your DB is still in California and routing certainly could slow down things :frowning:


Thank you for looking into this!

I’ve heard a lot about APC. I think I’ll give it a go.


I think you might be on to something in regards to the location of the physical location of the database.

Jen D, from DH support told me that my database was still in LA but my Web server was on the East coast. She told me that she had put in a request to have the database moved. Makes sense to me that closer they are are the better the response time.

Thanks, again, for looking into this.


I think you might be on to something in regards to the location of the physical location of the database.

Jen D, from DH support told me that my database was still in LA but my Web server was on the East coast. She told me that she had put in a request to have the database moved. Makes sense to me that closer they are are the better the response time.

Thanks, again, for looking into this.


I have recently made the switch from 5.2 to 5.3 and the memory reduction was huge, now I am looking at manually installing cache to help improve performance. However, I am seeing a huge difference in performance between one of my current providers (Handson ) and Dreamhost for an exact replica of this site. Now this morning the site just won’t come up. I am so depressed with trying to get Dreamhost working. This should not be this difficult, and the last thing I need to DH support telling me for the 15th time to check my site, look at the scripts, and adjust my theme.

There is no good reason why this stuff shouldn’t just work. Can’t even SSH into my VPS…