Site stability since adding Let's Encrypt


#1

Since adding Let’s Encrypt to my domain it seems my site (especially my Wordpress blog) isn’t up all the time like it was before. My site is fully hosted by Dreamhost and I no longer have CloudFlare added on my domain and I do not have redirect on.

On my Manage Domain page, I have “Leave it alone: Both http://www.mikepolinske.info/ and http://mikepolinske.info/ will work.” selected.

I get many messages a day from the Jetpack Monitor plug-in saying that my site is down and then after a random amount of time it is back up.

I updated the Wordpress settings to point to point to https://www.mikepolinske.info/blog and I’ve updated the .htaccess file in my root directory to be:

RewriteEngine On
RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$ https://mikepolinske.info/$1 [R,L]

Also, in Chrome on my Mac when I go to https://mikepolinske.info it says my connection is not private with the following code: NET::ERR_CERT_AUTHORITY_INVALID

Sometime when I go to http://mikepolinske.info I get “Site Not Found” and other times it loads.

So, I probably have multiple issues going on here, but I’d like to get them all resolved.

Is there anything I can do to get my site stable again?

Thanks in advance for any help.


#2

For one thing I would make a choice on www or not, and make the settings consistent all the way thru,
-force it in the dreamhost panel
-set WP admin the same way
-make your htacess redirect the same

Right now you have very conflicting settings between the Wordpress panel (includes www) and your htacess rewrite rule, which removes it.


#3

Thank you LakeRat.

I’ve updated my .htaccess to be as follows:

RewriteEngine On
RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$ https://www.mikepolinske.info/$1 [R,L]

And I’ve updated my domain settings to Add WWW: Make http://mikepolinske.info/ redirect to http://www.mikepolinske.info/

And my WordPress Address and Site Address are both https://www.mikepolinske.info/blog

We’ll see how that works out today.


#4

Well, I continue to get messages from Jetpack Monitor indicating my blog

Here at work on Chrome on Windows, when I try to go to the https site I get the CERT_AUTHORITY_INVALID error and when I go to the http site it comes up, but looks terrible as if it is ignoring the theme.

I noticed the Secure Hosting section of the panel.dreamhost.com, they’ve removed the Renewal option.


#5

I just tried, I get that error as well, I don’t know why.


#6

This is the error I get when I checked https://mikepolinske.info/

[quote]SSL verification issue (Possibly mis-matched URL or bad intermediate cert.). Details:
ERROR: certificate common name ‘sni.dreamhost.com’ doesn’t match requested host name ‘mikepolinske.info’.

[quote]


#7

Thanks kjodle.

I’m going to create support ticket with DreamHost. Hopefully they can help me out.


#8

I think what happened is that your SSL cert was issued when you had Cloudflare. When you moved off of Cloudflare, your DNS entry changed and the cert was still expecting to see a Cloudflare server. There was a mismatch, so the browser therefore thinks there’s some sort of man-in-the-middle hijinks going on.

I had a similar problem - I was able to resolve it by disabling https from the Dreamhost control panel, then re-enabling it (which re-issued the cert based on the updated DNS entry).


#9

Thank you, David. If I remember correctly Dreamhost had to do something on their end to resolve the issue.

I haven’t gone back to CloudFlare since, so I haven’t had any problem.