Site messed up


#1

it appears that my whole site is now messsed up. Is anyone else having problems with their site? My site is all php.


#2

I would send a message in to support. I am using php and am not having the problems you mentioned, but we are probably on different servers.


#3

Hi,

I’m getting the same problem, starting from 11am Monday. I’ve contacted support, but they claim that nothing has been changed.

Any ideas what could be wrong?


#4

Oh come on. Either they’ve changed something, or the machines have changed themselves (broken), or you’ve changed your site. If you haven’t connected to your site for days then you couldn’t have broken anything on your side. There must be a bottom line for this?


TorbenGB


#5

What are the sites with the problems?

josh!


#6

Something definitely changed over the weekend. My site was working fine on Sunday and broken Monday morning, with no changes from me.

I’m using Nucleus for my site, a PHP-based blog. The error on Monday was something about unable to read the “config.php” file. This file is included by most of the scripts in Nucleus. The permissions were set to 400, which has worked from the beginning of time. I should also mention that I was not running PHP as CGI. So on Monday, I tried changing the permissions on config.php to 444. Everything started working again. However, that file contains database passwords, so that was not a long term solution. I changed to running PHP as CGI, waited a day, and then changed config.php back to permission 400. Everything is working fine.

My conclusions: 1) DreamHost changed something Sunday night. 2) Running PHP as CGI is a good idea (not sure why I wasn’t doing that from the start).

Dave


#7

I’ve got exactly the same problems starting from Monday.
After contacting support they said I should not use .dataglob in any of my paths. I do not understand completely what
does it mean, and they don’t say what has been changed.

Alex


#8

“Dataglobs” are these weird things in our filesystem which are sort of a hidden part of the path to your home directory.

Like if you do an auto-install of a lot of different php scripts, they’ll set your path to be like:

/home/.yourdataglob/username/

which works.

BUT, the problem is your dataglob can change as we balance people among filers based on disk usage!

However, /home/username will ALWAYS work as your path. Unfortunately some common php script installers put in the optional .yourdataglob part, which can break them. If you go into your config and make sure all your paths look like just /home/username you should be fine from now into the future forever!

josh!


#9

My site was working yesterday. Now it’s busted again. This dataglob thing is definitely part of the problem, but I can’t figure it out. My index.php couldn’t be any more simple:

<? // This file will generate and return the main page of the site $CONF['Self'] = "index.php"; include('config.php'); selector(); ?>

And the error I am getting:

Warning: main(config.php): failed to open stream: Permission denied in /home/.iceman/username/site.com/index.php on line 7

[Username and sitename changed to protect the innocent]

But I can’t figure out where it is picking up the “.iceman” part of that?? I thought maybe it was in the PHP configuration, but I looked at the output of phpinfo(). No mention of iceman in there. Any ideas?


#10

I’m just now noticing a problem with my forum using the SolidClient component (which is PHP)…I go to the page with the forum and just get:

Error: Please check your account status.

This also occurs on the Forum Admin page…

Everything seems to be okay on my WebPanel admin page…anyone else getting this? It was all working fine this morning…the rest of the site is fine…have already sent a support email in.

-B


#11

Hi Josh

I have a support ticket open with virtually the same problems outline here, and they do seem to be this dataglobs problem; however, like the others my config paths ARE set to show just home/username/domain/directory nevertheless “some” but not all of my php scripts are picking up the dataglob problem and will not work.

I have been tearing my hair out and getting very upset/frustrated by this issue.

Can you please look into this since I can’t be the only person who is going to have this issue, and unless i can resolve it, I may well have to consider a host thats more php friendly.

My phpbb board doesn’t have this issue but my invision power board does.

my domain is www.the-snow-leopard.com


#12

I am getting dreadful problems with the .dataglob issue, the scripts keep looking on the wrong .dataglob.

All my paths on the board and in the global config are correct

home/user/domain/directory

yet it keeps overriding this and looking for the path

home/user/.incorrectdataglob/domain/directory

I’m not getting anywhere with support, and just can’t figure out how on earth to fix this.