Site down on VPS any ideas what else to check?


A site belonging to a customer of mine is down since about 5 hours.

They have their own VPS and Database VPS and run on WordPress. There is one other static site on the VPS that currently works intermittently.

My browser can’t establish a connection and a telnet test to port 80 gives me a “Connection refused”.

However I can ssh into the server.

I have rebooted the VPS (but not the DB VPS). There is enough memory (400 MB), it’s currently using next to nothing as there is no traffic coming through.

Timing wise it appears that the site went down when the http logs were rotated.

I have checked more or less everything I could think of, and sent a request for help to support. Does anyone have any ideas what else I could check or do while we wait?

The url of the site:
Since it’s a VPS I can arrange admin/root access if needed.

In case someone from support reads this, the ticket numbers are #5576965 and #5577017


Perhaps Apache is having trouble. Maybe see if a restart gives you any insight with error returns.

Also if you have Twitter, ping them @DreamHostCare - it may bring quicker attention to the issue.


Thanks sXi,

I did that as an admin user and got this (it repeats this several times always failing).

[quote]$ /etc/init.d/httpd2 restart
Stopping apache2-ps41383 webserver…not running.
Starting apache2-ps41383 webserver…starting…rm: cannot remove `/dh/apache2/apache2-ps41383/logs/__db.session_cache’: Permission denied
/etc/init.d/httpd2: line 76: /dh/apache2/apache2-ps41383/apache2-ps41383-httpd: Permission denied

There is a file __db.session_cache that needs to be removed. But I can’t remove it :frowning: probably because it belongs to root and I am a mere admin.
I tried the sudo variant as admin user, and got a different error message.

[quote]Stopping apache2-ps41383 webserver…not running.
Starting apache2-ps41383 webserver…starting…apache2-ps41383-httpd: bad user name watterbv

Well that rings a bell, it’s a user that I deleted yesterday (a very old site that we no longer needed). Aparently it hasn’t been completely removed from the system.


Pretty sure all Support can sudo in as root and fix this in a jiffy, especially as you know what the cause is.

Give 'em a tweet telling them how to fix it :smiley:

Oh… and count up the downtime hours 'cause your client may be due a week off their next bill.


I have now edited the hosting under manage domains, well didn’t change anything, just re-saved it. Hopefully that will rewrite the apache configuration file and remove this dead user…

Wow! It worked!

Thanks for the tip that set this off sXi!


This might be something the techs would be interested in (glitch-wise).

Maybe when someone from DH drops by they can make a note of this and pass it along.


Indeed. To be safe I’ll report my findings in a ticket, and link to this thread.


Hi Ottodv,

This is something that our admins should most definitely be aware of.
I see you already submitted a support ticket to our technical support team.
We’ll do our best to reply asap, however we are experiencing a higher then normal amount of tickets at the moment. Thank you for keeping everyone on the forums (and us) in the loop regarding this.
If I get any updates, I’ll post them here too.

Justin H
DreamHost Staff


Thanks Justin,

I wrote a more detailed ticket with I think all the relevant information regarding the underlying bug: #5577404

If still open the older tickets can be closed as the specific problem with my client’s site is now resolved. I withdrew the older tickets and don’t see them listed anymore.