Since server change, Word Press is broken


#1

Anyone else get an e-mail last night saying your site has been moved to a new server from Dreamhost? Now 3 of my sites that use wordpress are busted. Anyone know how to fix it, support hasn’t gotten back to me yet (must have hundreds of annoyed people with broken Word press sites).


#2

The first thing to check is that any config files and admin settings don’t contain dataglobs.

Change: [color=#00CC00]/home/[/color][color=#CC0000].dataglob/[/color][color=#00CC00]username/domain.com/[/color]

To: [color=#00CC00]/home/username/domain.com/[/color]

http://wiki.dreamhost.com/Dataglobs

Maximum Cash Discount on any plan with MAXCASH

How To Install PHP.INI / ionCube on DreamHost


#3

I saw this post and thought the same name, but can’t find a config file that actually has a path. I’ve even poked around in the database’s wp_options table and couldn’t see a site-killer path in there, other than the Uploads Path and Recently Edited. That’s minor breakage, though.

What’s broken on the site? Can it still be administered via wp-admin?

-Scott


#4

Yeah, WP does a good job of keeping it’s environment clean. The gremlins can sneak in during the installation of some of those plug-ins we’re all so fond of. If dataglobs are included during an SEO or caching plug-in install then a server move would likely be fatal.

A clearer indication of the problem or link to the affected domains would be handy. The good old “things are broke” line doesn’t really give us a lot to go on.

Maximum Cash Discount on any plan with MAXCASH

How To Install PHP.INI / ionCube on DreamHost


#5

http://www.prettyfar.com/wordpress/

Same here.
My gallery is also broken.


#6

Making progress. Found an instance:

wpg2 gallery plugin had:
/home/.investor/prettyf/prettyfar.com/gallery/

Edited to:
/home/prettyf/prettyfar.com/gallery/

Wordpress back up.

Gallery, not so easy. Still digging.

Edit:

Found it.
$gallery->setConfig(‘data.gallery.base’, ‘fubar path here’);

Hope this helps someone else.


#7

I can’t look at gallery, as you provided no link to it, but with your WordPress your whole page isn’t loading, as viewing source shows.

You might want to login to your WordPress admin section (it seems to be working fine at http://www.prettyfar.com/wordpress/wp-login.php) and try:

  1. Disable all your plugins

  2. Set your theme to the default theme

These are good general troubleshooting techniques as when you do one of these, if this site returns you know there is either trouble http://www.prettyfar.com/wordpress/wp-login.phpwith a plugin, or your theme.

–rlparker
–DreamHost Tech Support


#8

Ha! I was typing while you were working! Good deal, and good luck with Gallery. :slight_smile:

–rlparker
–DreamHost Tech Support


#9

See my edit, fast responce. :slight_smile:
I appreciate it.


#10

Man I really need some help folks. I’m having same issue. But I have no idea where the config and all of that is. Can I get a bone tossed?

Thanks so much

Lee


#11

What is the URL to your broken WP site?

–rlparker
–DreamHost Tech Support


#12

Basically I get the following error (see below) when attempting to upload photos to a gallery. Also the gallery thumbnails are all gone too, is it a php thing? link to one of the thumbs(http://www.themppc.com/gallery/showphoto.php?photo=353) . Please forgive my novice ability in this. Also, I am not using wordpress but vbulletin with photopost plugin but my problem is the same issue.

Warning: fopen(/home/.griff/c17lm/themppc.com/gallery/uploads/1/index.htm) [function.fopen]: failed to open stream: No such file or directory in /home/c17lm/themppc.com/gallery/pp-inc.php on line 3134

Warning: fclose(): supplied argument is not a valid stream resource in /home/c17lm/themppc.com/gallery/pp-inc.php on line 3135


#13

Your main site is vBulletin. Is the gallery part of vBulletin, or is it a third party that’s integrated within vBulletin?

It’s usually one of two things:

  1. The Gallery Admin page has a configuration section where you specify paths. Get rid of the .griff/ part
  2. Look for a config.php type file in your /gallery directory and search for that .griff string and get rid of it.

Thumbnail display is also handled by php, which is probably searching the same path for the thumbnail image.

-Scott


#14

Yeah i’m running a third party package for photo gallery. Checking the admin portion now. Stand by brb.

Update: The photo gallery is good to go. Thank you!

Checking vbulletin for it’s junk now. Thank you so mcuh for helping me and being so patient. Loving you guys since 2006.


#15

Ah! I see. This appears to be involving the setup/configuration of the Photo Post Pro, and it took a little digging to locate the source of the problem (where that .grif “dataglob” was being stored). Really, as this is a commercial product, the quickest way to get this sorted is to just contact the script author with your question, as he knows where he put all this stuff ;-).

That said, I did track it down for you. What you need to do is to change the contents of the various records in the pp-settings table in your database to remove the “.griff/” part (and there appear to be more than one such setting). With just a quick look I noticed several (I didn’t look through the whole thing):

Record id 6 (Full SERVER PATH to PhotoPost data directory)
Record id 81 (PATH to UPLOADS directory?)
Record is 208 (Orignial Image storage directory server path)

Start here, and change those, and you may have gotten it all. If not, please contact the vendor and ask where else to look to find these.

–rlparker
–DreamHost Tech Support


#16

I think I’m good at least to the point of getting my thumbs back. I need to findout how and which DB to access for now. Feel pretty moronic right now LOL. oh wait I found them in admin. Just to be sure before I contact vendor these appear correct right? or do I need full url extension?

/home/c17lm/themppc.com/gallery/data/


#17

Just out of curiosity - I notice your domain is forcing the www prefix.
Did you set that rule up after initially creating the domain in Panel?

Maximum Cash Discount on any plan with MAXCASH

How To Install PHP.INI / ionCube on DreamHost


#18

unfortunately I didn’t set it up. And since then like all websites the web help usually disappears on you. Please offer a suggestion on what I should do with that since I only know enough to be dangerous.

Lee


#19

It shouldn’t really affect anything, but you can change it in Panel.

I was only asking about it as I thought if you elected to use the www prefix that the Panel script setup the domain directory with the appended ‘www’ as well. I’ve dragged this off-topic a bit, my apologies.

Maximum Cash Discount on any plan with MAXCASH

How To Install PHP.INI / ionCube on DreamHost


#20

The database you need to look at to locate the table I mentioned is the database “themppc_forums” (you can find that, and the required credentials, in the config-inc.php file).

Just browse to the hostname for the database in that file, log in with the user and password in that file, and select the database in phpMyAdmin. The browse, edit the table I have indicated.

Note those are paths, not URLs, and really all you should be doing is deleting the “.griff/” from what is in the values - don’t change anything else and you should be fine.

–rlparker
–DreamHost Tech Support