Sinatra + Passenger + RVM


I’m having trouble running sinatra server.

I installed RVM and got a simple sinatra app, sources below. I created public + tmp folders as well. I followed some articles on how to set the GEM_PATH/GEM_HOME.

The site is defined with “Passenger (Ruby/Python apps only)” option.

If I run the standalone passenger, with the command line in SSH, it works fine on port 3000 (with public URL, e.g. So it means the site is fine, gems are available, it’s just the connection to Passenger that fails.

I can’t even see the logs from apache to see what’s wrong. The /home/user/ is empty, and the access.log is filled with 500s.
The error in the browser is 500, Internal Server Error.

What am I missing?


Source files:

# I made sure the path is correct and that all the gems I need are installed there
ENV['GEM_PATH'] = '/home/junkie/.rvm/gems/ruby-1.9.3-p362'
# I tried also setting GEM_HOME instead and with GEM_PATH

require 'rubygems'


require 'sinatra'
require File.expand_path('../server.rb', __FILE__)
run Sinatra::Application


require 'sinatra'
get '/' do
  "Worked on dreamhost"

get '/foo/:bar' do
  "You asked for foo/#{params[:bar]}"


Have you made any traction on this. I am facing the same issue. I can rackup my app with no problem but seems passenger isn’t reading my When I try a web request I get

Application error

Pinprick couldn’t get Sinatra on stage.


Nope. Ended up closing the account.
I think if you daemonize the process you can use an external tool they sell to forward the port from 8000 to 80, but that would double the payment and make DH unattractive.