Shtml


#1

hi all.

my site uses shtml because it uses some simple server side includes. They were rendering fine yesterday, but today noticed that in Firefox (v1), they no longer render. if I view the site, they come up as plain text, as if I chose ‘view source’.

If I view the site in IE6SP1, it renders fine.

I’m including a header and footer in the pages, and they are being included properly, but Firefox isn’t rendering them.

If I rename to html, and add an .htaccess file with the line AddHandler server-parsed .html included, the page renders fine in both Firefox and IE6.

Could someone give me some pointers as to why Firefox is refusing to render shtml files? It’s occuring on multiple machines. Unfortunately I can’t give the URL since I’m still testing and haven’t moved name servers.

Thanks,

David.


#2

Very curious. I use Firefox 1.0PR–I do not have a problem viewing shtml pages.

  • marsbar

#3

ya…I don’t understand it either. It was working fine yesterday, and today, nada. Just the source. It must be something I changed on the server, since it’s affected both domains I have here, and it’s happening on multiple clients. One’s running the Firefox 1.0 ‘Gold’ release, and one is using 1.0PR.

Now that I think about it, I do have a domain available…could someone try www.glassroom.ca and let me know if you get source, or a properly rendered page? It’s the index page from the site I’m setting up. Both domains are on the same account, on the same DH server.

Thanks…


#4

I have tried the page in NN7.1 and Firefox 1.0PR and got the source (but MSIE6 is happy). There probably is a server setting problem.
All the best,
marsbar


#5

It’s a server configuration issue. This could be a problem with DreamHost or perhaps something you have in an .htaccess file.

The HTTP headers are saying the content media type is text/plain instead of text/html

Unfortunately IE will sniff the content instead of trusting the person who is running the web server or the webmaster.

:cool: Perl / MySQL / HTML+CSS


#6

very strange…I searched the directory tree on the server and I don’t have any .htaccess files on the site.

Guess I’ll open a support ticket with them.

Thanks!


#7

Really good idea to contact support on this. I get the source in Firefox 1 as well. Just wanted to point out for future reference that you may have to set up your ftp client to show all files, including hidden ones, to view htaccess files.

~Chell


#8

hi there.

I logged into the shell and did a search there…no .htaccess :slight_smile: But, I did contact support, and they had the admins look at it. Appears they fixed whatever it was as I can now view the pages properly. NIfty.

Am pretty curious to know what it was though.

Thanks for everyone’e help!

David.