Show 'www' in URL when searching on Google


#1

When I make a search for my website, Google shows my URL without ‘www’. I checked the option ‘Add www’ on ‘Manage Domains’ config but it remains the same.
How can I fix it?

Regards,
Wellington Gomes


#2

Wait a bit. The Googlebot should pick up the changed URL next time it visits your web site to index it. It may take a few days, but they’ll notice eventually.


#3

Google shows ‘xxx.com’ link instead of ‘www.xxx.com’.
My website is online for more than a year and it stills the same. Also, my website has a good number of visitor each day.
Someone can help?

Regards,
Wellington Gomes


#4

Both will take your visitor to the same place anyway


#5

the Dreamhost settings can be overriden by your website, so you need to make sure your site matches whatever you want it to be. Is this a wordpress site?

I tend to set DH to remove www. but then I also make sure I add a rule on my .htaccess file to make sure that it truly does what I want. You instead want the www to show always. Once you set that, google will start reflecting the www (after some time). The surest way to do this is to add a redirect rule in your .htaccess file that ALWAYS forces that your site is served with “www”

You’ll need something like this in your .htaccess file

//Rewrite to www
Options +FollowSymLinks
RewriteEngine on
RewriteCond %{HTTP_HOST} ^example.com[nc]
RewriteRule ^(.*)$ http://www.example.com/$1 [r=301,nc]

And while this is true “Both will take your visitor to the same place anyway” – it isn’t ideal for search engine placement because http://www.example.com and http://example.com could be considered two different sites even though we know they aren’t. Its just a technical thing with filenames and paths.