Shell setup, termcap, colours, etc


#1

I’m a Dreamhost shell user for several years, and so far I’ve just “put up” with the difference between the shell on my home computers and when I ssh into Dreamhost.

This means I put up with no or odd colours in vim, screen scroll-back and altbuffer not working properly, the usual BackSpace vs Delete rubbish, midnight commander not showing vertical lines but instead odd utf chars, etc. The common things you find when you use a remote shell.

I do everything within screen to get around the crazily short session time-out that Dreamhost uses, so now I’m dealing with termcap issues in the shell AND screen’s silly quirks.

So far I’m trying to fix it with ‘export TERM=vt100’ in .bash_profile. But Dreamhost’s vt100 termcap entry seems a little odd, and it hasn’t really fixed it.

I very much doubt I’m the only Dreamhost customer who uses screen and the shell to do everything. I’m hoping that someone has “just fixed it” for themselves and can give me some guidance on what to do. Otherwise I can see I’m up for hours of trying to debug the abomination that is termcap.

Many thanks for any help.
Nick


#2

Don’t set TERM=vt100. That terminal definition is extremely limited, lacking a number of useful features like color and a page up/down keys.

What SSH program are you using to connect to your server? The correct TERM setting will depend on that. A few common ones to try are “xterm”, “xterm-color”, and “rxvt”.


#3

I know this thread is dated, but it was my first result when trying to solve a similar issue. When using ‘screen’, the terminal colors were monochrome (but not in vim under screen, oddly enough). To get color while using ‘screen’ , I had to switch shells. In my ~/.screenrc:

shell -/bin/bash

Hope this helps the next person…