Sharing data between users


#1

I’m trying to share a directory between multiple shell users. Therefore I created a custom group, added the membership to the users, and changed the group permission of the directory with chgrp.
But when I log in with a different user and try
ls /home/shareuser/shared_dir/
I get an "/home/shareuser/shared_dir/: Permission denied"
error.

What am I doing wrong?


#2

Did you activate the “Extra Security” option?


Julian Knight


#3

Was deactivated, didn’t make any difference.


#4

I have exactly the same problem on 2 of 6 domains.

Maybe I failed to deselect the extra security whilst creating them initially, I really can’t recall, but unchecking the box now certainly makes no apparent difference to permissions at all. I’m guessing the switch in Panel only changes permissions on future files and isn’t a switch that runs a script over the account. ie Once something is created with that flag the only way back is to login on the original shell account and change all existing permissions manually.

Think it might be easier (in my case) to remove everything and FinneganBeginAgain before I upload any additional content than I have already, which would further compound the situation.


#5

I’ve tested this on my own account and it does seem to be correct that you cannot access the SSH/FTP account of a user that was set up initially with the extra security - I suspect that their home folder retains the additional security even after it has been turned off.

An existing user CAN access the SSH account of a new user that was set up without the additional security.

Regards,


Julian Knight


#6

Ho ho!

If you ssh log in to the account you can’t currently share as the proper user, you can change the permissions to correct this using the following command:

chown : .

If you’ve disabled the extra security flag already, you will see what the correct grpname is simply by doing :

ls -la

You will see that the settings for the folder “.” are :adm until you change them with chown.

Enjoy!


Julian Knight