Shared files


#1

I have three users on my account who have access to the shell. I’ve created a group to which all three of us belong. I then chgrp some folders and files that I want to share with my friends. Then I tried to ln -s those shared folders into my friends’ /home/friend_name directories. The links are unfortunately not accessible, even when I chgrp them to the group we all belong to.

Any help will be appreciated


#2

It’s quite possible that if the parent directory isn’t also chgrp’d, then they won’t have access to the child directories.

But first, how are your friends trying? If it’s FTP, then I doubt it’ll work. Try SFTP instead.

A link is more a map than a shortcut.

-Scott


#3

We try through bash shell only. I know that a link is only a pointer but without it my friends can’t get into my home directory (it gives a message: permission denied); that’s why I thought I’d use ln -s to point those folders and files to their directories. I have no idea why this is not working.


#4

Anyone with a suggestion how to get it to work?


#5

I still haven’t heard if you chgrp’d the parent directories to let them in. And don’t forget to chmod to allow Group access, like if a directory is 700, the owner can read/write/execute(enter), but nobody else can. It needs to be 770 (or 775, etc). The first and second octet need to match.

-Scott


#6

Hi Scott

Yes, all shared directories are granted that privilege, so that /home/my_name_directory/shared_folder is under the group (group_name_shared_between_friends), and chmod is set to 775. The problem is they can’t access my home directory. They get a permission-denied message.


#7

You might want to check the users again and make sure you have tihis turned off:

http://wiki.dreamhost.com/Enhanced_User_Security

:cool: openvein.org -//-


#8

Thank you, that is a good lead, but there is a problem. If I create a new user and don’t check Enhanced Security at the beginning, indeed everything works perfectly on the new user’s home directory --when he shares a folder with a friend within that shared group they are in-- if the friend has not done checking that feature as well; once one of them checks it, and then undo it, it will not work again.

Any suggestion how to make it work when the checking has been done before?


#9

Contact Support, explain that for the users you need the home directory group id changed back to your group. And mention that unchecking Enhanced Security didn’t appear to work for you.

:cool: openvein.org -//-


#10

Wrote to the customer support and they solved the problem.

That’s what they wrote back:
"> The feature works when I create a new user and I don’t check 'enhanced

[quote]security’ at the beginning; once it’s checked and then undone, it will not
work again.

[/quote]

Ahh ok. Fixed. What happens with the Enhanced Security setting is that
your home directory is changed to another group. "