Sh - bad interpreter error

software development

#1

Ah ha! I found the problem I kept having when trying to install packages through pecl.

Turns out there’s a small bug with the cross mounting for the temp directory as stated here:

[quote]The problem with this situation is that you are trying to run a shell file on a partition for which you have no exec rights. I.e. an USB disk, a CD or DVD or some extended, logical hard disk or network partition.

In my case, I have my home dirs installed on a different partition, /dev/hda5. (This gives me freedom to reinstall Linux any time without tampering with my users’ data and config/settings.)

Solution:
Anyway, I needed to add the ‘exec’ option to the /etc/fstab file when mounting that partition. :slight_smile:
If it says ‘defaults’ on the line in /etc/fstab, then it also means you don’t have exec rights on it.
Easy as pie! Piece of cake!

Another workaround, when you can’t or don’t want to mess with the fstab, is to compile/install source only from /tmp. That will always work![/quote]
I hope somebody at DH is reading this and can fix this.

I’m trying to get extensions installed using pecl but kept running into this error. After some debugging, I’ve determined it was an issue with the shtool file. A but more debugging and If found out I was right and the above is the exact problem!

For those of you that didn’t know; /tmp is actually a cross mount.

Hope you DH dogs (err, I mean gods!) can get this fixed. :wink:


limbo-postal# rm -rf /etc
limbo-postal#


#2

Oh, found a work around – used pear config-set to change any config option that uses /tmp to use my own temp directory. That seems to work.


limbo-postal# rm -rf /etc
limbo-postal#


#3

Thanks for posting that. That’s a nice piece of work determining the problem, and a workaround. You should stick that in the wiki! :slight_smile:

–rlparker