SFTP with sftp OK - with filezilla not OK?


#1

If I use sftp from the bash prompt I can connect to my server as I would expect to …

$ sftp foo@example.com
foo@example.com's password:
Connected to example.com.
sftp>

However when I try to make a connection from filezilla I don’t get an error message but after 20 seconds you see the message ‘timed out after 20 seconds of inactivity’ like this …

|Status:|Disconnected from server|
|---|---|
|Status:|Connecting to example.com...|
|Response:|fzSftp started, protocol_version=8|
|Command:|open "foo@example.com" 22|
|Command:|Trust new Hostkey: Once|
|Command:|Pass: ***********************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************|
|Error:|Connection timed out after 20 seconds of inactivity|
|Error:|Could not connect to server|
|Status:|Waiting to retry...|

Both the filezilla and the sftp sessions are initiated from the same machine, a Xubuntu 18.x instance. I get the same response in filezilla whether I used the Site Manager or the ‘QuickConnect’ . In Site Manager I have set up the remote directory (I read elsewhere not doing that can cause problems).

Any ideas on what might cause this ? Thanks.