Sftp error exit code 128


I am having a problem connecting with one (and only one) of my user ID’s through SFTP. before anyone suggests that my settings are incorrect on my end in the software, or in the user settings on the dreamhost panel:
I have two user accounts configured identically (except they have unique names of course) on dreamhost.
ID1 connects fine (I am using filezilla).
ID2 gets this error.
I have configured both accounts to use the same password temporarily, and can take the site manager for my website and ONLY change the user name, ID1 connects fine, and ID2 will not. this test I think validates my local settings.
Both user accounts have the EXACT same setup in the Dreamhost panel.
I have tried using a terminal on a linux machine to sftp from the terminal window, and I get “connection closed” with no other messages, again, only with ID2, ID1 connects with no errors.

A google search comes up with very few specific results for this error:
ALL state something about the version of windows server that the OP was connecting to.
Dreamhost is not using windows servers, so most of what they say does not apply.
The only other information I have found involves changing a line in the .bashrc file, in /etc on the server (not something I have access to, and if it was the problem, ID1 would also fail). there is a copy of that file in my home/ID1 and home/ID2 directories, the line is NOT in either file.
Another search result states to validate the permission settings for the FTP folder
I have tried not specifying a directory, AND specifying the /home/ID2 directory as the starting location, both cause the same error.
The user ID2 is the owner of the home/ID2 directory.
The owner has rwx permissions on their home directory (both ID1 and ID2).
I do not have an htaccess file in the home directory for either user.
ID2 has 2 websites stored in their home directory, ID1 has “previous iterations” of those same websites stored in it, but none are accessible on the WWW by typing in the URL, they are saved copies in case I want them for nostalgia, or to create subdomains using them at some point in the future. This is the only difference between the accounts as far as I can see.

again the error message on connection is: connection closed by server with exitcode 128.

any help would be appreciated, although I do not see anything I have missed in troubleshooting this issue (which is why I am asking for help… :slight_smile: I am plumb out of ideas)


Since that is a server error you might want to contact Support and ask them to review the logs if possible. However you may want to try changing the password for ID2 if you haven’t already.