Sftp: can't read/enter home directory


When logging into sftp I get rejected from viewing my home directory.
I am a user but not an admin user.
I can login shell into the directory
The output of: "ls -al / | grep home " is
drwxrws–x 35 root staff 16384 2009-03-30 15:14 home
and the output of : “groups {username}”
{username} : pg1644200
now from the following command: /usr/sbin/usermod -G staff {username}
I get: “usermod: unable to lock password file” so I can’t become part of the staff group and with execute only permissions as “other” user, it seems I won’t be able to read the directory.

Any ideas about how I should get sftp access to the directory? otherwise I’ll have to use ftp. And that’s “not right”.


Are you that very same user? You’ll never be able to join the staff group, but that group is not associated with your home directory.

What I see you doing is doing a listing of /, which is root of the server - not your home or domain “root.” If you want to examine your directory, use ~/ or just ~. The tilde means “user’s home directory.”

FTP is different in that you are sandboxed into ~, so a / in FTP is really /home/rupert160 (or whatever) in SFTP and shell.



Okay that makes about not becoming a member of staff. What is not making sense is that I can get access to “/” a bunch of other directories off the root but not navigate up “/home” to get to “/home/rupert160”. One other problem is that the “one click installs” are placed in my mate’s directory (the virtual server owner) “/home/mymate” so I need to navigate into home (I guess I could navigate directly there, but it’s not “proper”) then to /home/mymate.


Use a symlink from within your own userspace:

cd ~ ln -s /home/mymate/somefolder mymate

Maximum Cash Discount on any plan with MAXCASH

How To Install PHP.INI / ionCube on DreamHost


I believe that the “Enhanced Security” would prevent you from getting into your mate’s directory.

At one point, I tried to turn this off, but needed Support’s assistance to reset the permissions to open it up for other users in my Group. I don’t know if it was a glitch, or a “feature.”



Yeah, if you preset the user’s home using the Enhanced Security option then only root can change the permissions allowing other group members to access that userspace, which would necessitate that Support step in to reset permissions for you if you’ve chosen the tighter security model when first creating each user.

I had the same results as Scott when I tried reverting via Panel. Could be that an attempt to revert via Panel might not be chgrp’ing back to the account pg* default or something along those lines.

Maximum Cash Discount on any plan with MAXCASH

How To Install PHP.INI / ionCube on DreamHost