Setup Problem

This is unsual as I have never had problems setting up with a host before - this is my 5th - but I’m having trouble setting up my domain

I own; which I have pointed towards DreamHost.

My domain registrar told me to put the IP as well so I said because that is the www IP listed under my DNS settings.

Logging in to the WebFTP i have put an index.html file in the root folder. I have also created a folder in the hope that this will work (this worked on another account once) and put an index.html file in there too.

What do I do?

And second question, I can do HTML includes yeh?

Plus I want to do an Apache 301 Redirect from, can I do this on these servers…?


I don’t think you should put that IP address. We are in a shared server and the IP address may change after a while. Is there a way for you not to put the IP address but only the DNS?

I believed that you have added the domain to your hosting plan via DH panel --> Domains --> Manage Domains --> Add Domain / Sub-Domain. Otherwise you won’t be able to upload files via WebFTP.

You don’t need to create folder if you log into WebFTP as it is already inside If you log into FTP, you will be in your home folder which contains “Maildir”, “Logs”, “” folders.

You can do HTML includes here.

You can use .htaccess to do redirect here.

Save $97 (MAX Discount) with code: [color=#CC0000]97YES[/color] Sign Up NOW or More Codes Here

First, you should always put in more than a single DNS server or IP address. From the old DreamHost knowledgebase:

"First you’ll need to login to your domain registrar (the company with whom you registered the domain.) You’ll then need to change your domain’s DNS settings so that your domain points to our servers. Our DNS settings are as follows:"

Note that those are the IP addresses of the DreamHost DNS servers, and they are what you should be using, not the “” ( that is the www IP listed under DNS settings in the DH control panel, and is subject to change at any time). All your registrar should need to know is how to “point” to the DreamHost DNS servers, and they should route the request to the appropriate DreamHost assigned IP address as necessary.

Nothing you put in the “root” folder as displayed by webFTP will be visible from the web, as that is the “user” folder beneath which any “sites” for that user are located.

You had the right idea by adding a directory/folder under that directory as your domain name (, but the fact that you had to do that “manually” makes me think you missed a setup step.

When you “Add a Domain/Subdomain” to be hosted via the Control Panel -> Domains -> Manage domains screen of the control panel, it will create/assign a directory under your “user root” for the domain and associate that with your domain for the purpose of serving web pages for that domain.

Go to that control panel domain management page, and see if your “” is listed there as a “fully hosted” domain. If it is not, click the “Add a New Domain/subdomain” link, and complete the provided form to “add” the domain to your hosting package. Note that you will have an opportunity on this form to define the directory that you want to be the “base” of that domain’s pages.

If your domain is listed there, then click the “edit” button under the “web hosting” column for the domain, and confirm the directory setting previously mentioned accurately reflects the directory in which you are storing the files to be servd over the web.

You can use either SSI (.shtml) or PHP based includes on DreamHost. SSI instructions are available on the DreamHost wiki (, and there are many tutorials on how to use PHP to include other files.

If you want to use SSI with .html files (instead of with .shtml files) you will need to make allowances for that as discussed in this DH Wiki “How can I use ssi on files with .html extensions”.

Sure, just use .htaccess to set it up - there are lots of examples of how to do that on the web and/or in the DH Wiki.

The DH Wiki has a lot of very useful information about this and many other DreamHost related tings, and you should explore it a bit to see what is there. :wink:

Just a though here: If you have unrelated/different questions in the future, it is more helpful to other users of these forums if you post each question as a separate post with a descriptive title that describes the subject. This makes it easier for those browsing the forums (for information or to offer help) to identify a post in which they are interested or for which they can provide help, and makes it easier for subsequent visitors to track the answers that are given for a particular subject. :wink: Oh yeah, and “Welcome to DreamHost”. :slight_smile:


That might seem to be the case at first glance but, if you stop and think about it for a minute, you will realize that as long as he has an FTP, SFTP, or shell user created, he can use tools (including webFTP) to upload files to, and otherwise access, that user’s directory. :wink:

Sure, he couldn’t yet use his “domainname.tld” as the host/server name, but he could use the actual server name (“”) as he is instructed in the email he receives from DreamHost.


Hi all

Thanks for your wonderful replies. now works… :slight_smile:

The problem was I was logging on as another user. ( I set up a second user account with an easier login name) I was reading some other threads here where I saw that this would create issues… tried the original username… and voila :slight_smile:

Your welcome, and I’m glad you got it sorted out!

Yeah, that’ll result in your files being stored under that user, as you have figured out. :wink:


Haiz… I missed that point :frowning:

Save $97 (MAX Discount) with code: [color=#CC0000]97YES[/color] Sign Up NOW or More Codes Here