Setting up X server on dedicated server?

vps

#1

Hello, so I have been trying to get an X server running for a few hours now and I keep hitting roadblocks. It appears that the reason I can’t get it running is because of the AST driver for the ASpeed GPU (?) that is in the server. I installed the drivers, but it isn’t really wanting to recognize that they are there. Has anyone had success with this?


#2

What are you trying to accomplish by installing an X server? You do not have physical access to the server, so making a graphical interface available on the console won’t do you any good.


#3

Well one of the programs I am trying to run for my server requires a background window to open which won’t work without either an X server or a VNC server. I have tried VNC but it keeps telling me connection refused so now I am trying X and it is pretty much telling me I need the graphics drivers.

Edit: Never mind, I got it working. I had to install XMing and set X11 forwarding flags. My biggest issue was that when I would first login, I would login as a root user so the user I would switch to after wouldn’t have the xauth list propagated with the keys. After signing in with the correct user, I was able to start the programs with no issues.


#4

X forwarding will work for running applications interactively. The program will stop running as soon as you disconnect from the server, though. If you need to have a graphical program keep running in the background, you’ll need to set up a VNC server or similar.

(If you do set up VNC, please make sure to secure it properly. Setting the server to only listen on 127.0.0.1 and connecting to it over an SSH tunnel is a good idea, as the protocol is not encrypted by default.)