Setting up stats page

wordpress

#1

What do I need to do to get my stats to show? Do I need to set up a page within my site? I use wordpress if that matters and I’m not html savvy.


#2

I should add this to the wiki someday, but here’s a recent post of mine:
http://discussion.dreamhost.com/showflat.pl?Cat=&Board=forum_troubleshooting&Number=50834&page=&view=&sb=&o=&vc=1

-Scott


#3

Awesome thanks. Now is there a page that translates what I am seeing:p


#4

Personally, I prefer AWStats. It’s nicely formatted and pretty informative. I have a zip file of a default installation that I usually put in /statistics:
http://www.scottdayman.com/awstatspackage.zip

-Scott


#5

Sorry but that made me even more confused. It says to run a script but that script is in text format. Then the rest of the instructions are way over my head.


#6

That got me a bit further, but I’m still getting this error when trying to view my stats now for either domain I host on here, any ideas?

Parse error: syntax error, unexpected T_STRING in /home/.intrepid/xxxxxxxl/logs/videostoregf.com/http.1498569/html/monthly/2006-08/index.html on line 1


#7

That’s a PHP parsing error.

Did you modify your .htaccess file to run .html documents as PHP?

The stats documents are XHTML and begin with the XML prologue and another XML processing instruction. If passed through PHP and short tags is on, PHP will try to parse these as PHP code.

From the online documentation:

[quote]There are four different pairs of opening and closing tags which can be used in php. Two of those, <?php ?> and , are always available. The other two are short tags and ASP style tags, and can be turned on and off from the php.ini configuration file. As such, while some people find short tags and ASP style tags convenient, they are less portable, and generally not recommended.

Note: Also note that if you are embedding PHP within XML or XHTML you will need to use the <?php ?> tags to remain compliant with standards.[/quote]

So I’m thinking you either have a custom PHP build or php.ini file and you pass .html files through PHP from your .htaccess

:cool: [color=#6600CC]Atropos[/color] | openvein.org


#8

All my .htaccess file contains is:

BEGIN WordPress

RewriteEngine On RewriteBase / RewriteCond %{REQUEST_URI} ^/stats/(.*)$ [OR] RewriteCond %{REQUEST_URI} ^/failed_auth.html$ RewriteRule ^.*$ - [L] RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule . /index.php [L] # END WordPress

If I need anything else in there, please let me know what’s missing, as DreamHost has ignored my open ticket for the past 2 days! Thanks!


#9

Are you running the domain as PHP-Apache still?

What you need to do is this:

Make a PHP file on your domain that contains this:

<?php phpinfo() ?>And then either post the URL here or if you prefer send it by Private Message. Also check login to the Account Control Panel and check under Domains and tell me if it is PHP 5 or 4.

:cool: [color=#6600CC]Atropos[/color] | openvein.org


#10

Well you’re running PHP 4 as CGI on Apache 2. I’m not running under Apache 2 yet myself, so I’m assuming its a server configuration issue.

Try this. Rename the PHP file to have an .html extension, then browse to that file. If the PHP info page shows up, then for some reason you have PHP parsing .html files as well, and if that is the case, go to the Account Control Panel for your domain, and Edit the domain and click on the “Change fully hosted settings now!” button to update the server configuration. Wait maybe an hour and see the .html file is still being parsed by PHP.

:cool: [color=#6600CC]Atropos[/color] | openvein.org


#11

Ok, I just unzipped the AWstats package and uploaed the whole shebang into mysite.com without altering anything. Is that correct? When I go to mysite.com/stats its still the dreamhost format. When I go to mysite.com/statistics I get a username/password prompt. Nothing I put in works. What am I missing?


#12

You’ll definitely need to alter a couple of things:

  1. Edit awstats.conf and replace USER and DOMAIN with your username and domain name
  2. Edit index.html and replace DOMAIN with your domain name
  3. Delete .htaccess and .htpasswd
  4. Add the following to your crontab:
    59 23 * * * /usr/bin/perl /home/USER/DOMAIN.com/statistics/awstats.pl -config=DOMAIN.com -update > /dev/null

If you need help with editing files, or your crontab file, visit http://wiki.dreamhost.com for help.

Then go back to mysite.com/statistics and click the Update link at the top.

-Scott


#13

Can anyone recommend a stats program that is simple to use and setup? I’m sorry but this thing is complicated for me. I don’t like going in and trying to mess with the guts when I have no idea what I am doing.