Setting up custom php.ini


#1

I needed to change the upload_max_filesize for my site so I followed the directions at http://wiki.dreamhost.com/PHP.ini to create a custom php.ini file.

I followed the directions and double checked the file permission settings.

When I try to view any page on my site, the php-wrapper.fcgi file comes up in plain text.

Here are the contents of my php-wrapper.fcgi file:
#!/bin/sh
export PHPRC=/home/username/mysite.com/cgi-bin
exec /dh/cgi-system/php5.cgi $*

Here are the contents of the .htaccess file I created:
Options +ExecCGI
AddHandler php5-cgi .php
Action php-cgi /cgi-bin/php-wrapper.fcgi
Action php5-cgi /cgi-bin/php-wrapper.fcgi

Can anyone give me a suggestion? I’m very new here.


#2

The Wiki page probably needs to be updated, it skips an important step …

Make sure you have “FastCGI Support?” checked off for your domain in the Web Panel -> Manage Domains.

Also did you set the permissions to 755 ?

Customer since 2000 :cool: openvein.org


#3

Hi,

Thanks, it seems to be working correctly.

I enabled fastCGI support. Which the wikki did not mention

The wikki stated that the file permission for the wrapper.fcgi fie should be 755 and the permission for the php.ini file should be 640 which seems to work correctly.

Thank you, this has been a liberating experience, I had never used the terminal on my computer before I attempted this, in fact, I had to look up the definition of SHELL! . Thanks for helping me through.