Setting up a subdomain for the stats

Hi There,

The CMS I am using seems to interfere with the /stats directory so that when I type in the address, I am returned to the homepage.

So what I have tried to do is create a subdomain that points to the /stats directory called However, when I visit that subdomain the page returned is a blank white page with titled with ‘Index of/’.

Any ideas what I’m doing wrong?

This is actually a pretty common occurrence, and is caused by the CMS’s re-write rules interfering with the navigation to the subdir.

You didn’t share which CMS you are using, so I can’t respond with complete detail, but the fix for this situation is actually very simple. The DreamHost wiki has an article on this called Making stats available with .htaccess" which describes how to modify your .htaccess file to allow the stats dir to be served in this situation.

The article uses a WordPress installation for it’s example, but the process is very much the same with other CMS systems. There are some other specific examples also in the wiki (see

Even if your CMS is not shown in a specific example, if you study the examples that are available, you should be able to figure out what you need to do in your circumstance. :wink:

The subdomain pointing to the stats dir isn’t going to work (as you discovered), so you will need to tweak your CMS .htaccess as indicated in the above paragraphs to let the stats dir “slip through” the re-writes.


If you install awstats to the sub domain you could still set up the configuration to use the stats for whichever site you want. This would achieve this.

If you want similar stats to the dreamhost default it may be possible to install your own version of analog.

$50 DISCOUNT [color=#CC0000]DISCOM50[/color] Extra Value codes with extra features

Hi and thanks for your help, I’ll check out what you have outlined below.

The CMS system I use is called Typo3.

You are welcome, and good luck! That second link I supplied has an example for “Typo” (same as Typo3?)


Fantastic and thanks again for your help, the code for the quick fix option worked perfectly for me.