Setting Apache LogLevel


#1

Is it possible to increase the LogLevel that a site hosted by Dreamhost is reporting? I’m on a shared host and obviously don’t have access to the server config. Is there another way to set the LogLevel, like through .htaccess or something similar?

Thanks.


#2

Not directly. What sort of information are you looking for?


#3

I’m getting a redirect loop due to a mod_rewrite rule and I don’t know why. I would like to set LogLevel to debug to track the redirect.


#4

Might want to post what you have in your .htaccess file to see if someone can give you an answer :slight_smile:


#5

I don’t have anything at all in my .htaccess file regarding logs. The RewriteRules I have are:

Options +FollowSymLinks RewriteEngine On RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule ^objects/(.*) /objects/index.php?oid=$1 [QSA,L] RewriteRule ^user/(.*) /user/index.php?uid=$1 [QSA,L] RewriteRule ^tools/(.*) /tools/index.php?tid=$1 [QSA,L]

The rule of the objects directory works just fine. The rules for the user and tools directories give me an ISE due to a redirect loop.


#6

You’ll need to repeat the RewriteCond lines for each of the RewriteRules - as written, they only currently apply to the first RewriteRule, which is probably what’s causing your problem.

Alternatively, it might help to move objects/index.php to objects.php (and similarly for user and tools) so that the RewriteCond lines aren’t necessary in the first place.


#7

Thanks, that was exactly my problem.