Session Trouble


#1

Hi, I just moved to DreamHost and I’m having a huge problem with my site. I’m getting an error that I don’t understand. It has something to do with the session_start() that I’m performing to instantiate my shopping cart. Any help would be greatly appreciated.

Here’s the page that shows the errors I’m getting. http://www.emmasbridaljewelry.com/inner/bridesmaid/necklaces

P.S. I just transferred the nameservers around noon today, so hopefully that won’t cause any trouble, seeing as how the servers may still be kicking in.


#2

Ok, I feel really dumb now. I was sweating to death over nothing. I had a cookie in my browser from the previous server. So the server path was all wrong. ha ha =)


#3

Ok, I’m going to have to take that back again. I’m still having the same problem. When I delete the cookie, it works in initially creating the cookie/session, but when it tries to make another call to it on another page, it throws up an error message.

help =(


#4

While not an expert on this subject, I think my input might help a light go on for somebody reading this. You seem to have a mismatch in your configuration somewhere. Cookies from “emmasbridaljewelry.com” and “www.emmasbridaljewelry.com” are not interchangeable.

You have your domain set up to always add “www”. If I go to http://emmasbridaljewelry.com, my browser settings show a session cookie with the correct value, but there are some differences. The site is listed as “emmasbridaljewelry.com” but the HOST value for the cookie is “www.emmasbridaljewelry.com

That causes your site to throw the following error:

If I clear my cookies and then browse to http://www.emmasbridaljewelry.com/, the new browser cookie shows www.emmasbridaljewelry.com for both site and HOST. The error then goes away, and everything seems fine. As soon as I click a link, the session blows up and I get the same error message. When I check my cookies again, I see the site has been reset to emmasbridaljewelry.com, and no longer matches the HOST.

What happens if you configure your domain to always remove “www” in the DH panel?

http://benconley.net
http://teamshocker.com