Serious problems after switching to 5.4

vps

#1

I’m having serious problems with my site after switching to 5.4

Everything was fine until tonight when I decided I needed to add a new/extra session variable to my login class after a user successfully logged in. Inside the IF statement for a successful login, I added a new SQL query, and then set the new session to a result from that query.

Didn’t work. So I tried the usual debugging practices of commenting out code. Didn’t work. I tried just setting it to a number and a string and not the SQL result thinking it was a problem with my query.

STILL didn’t work. Commented everything out including having it set the only other session variable it had been setting.

I logged in, and on my landing page after a successful login (welcome page) I printed out all the sessions I had set using a foreach. It was still showing that this session was still active, the new one wasn’t there though. Cleared all cookies multiple times, even used google ingocnito mode.

I have gone as far to comment out the redirect that I was having it set upon a successful login and it is STILL re-directing me. Further, adding in echo’s will print the new “echo” statement on the landing and login page.

Ideas?

After talking to livesupport, they were nice enough to try and see what the issue was.
I had the idea while talking to them to see if for some reason my FTP wasn’t updating the files so I logged into shell, updated the file manually. It was missing all the changes I had made, but for some reason allowed me to update via SHELL to comment out lines.

Long story short, after that I tried again with FTP and it worked again. Checked my FTP error logs and I had none. No idea what happened, seems to be working again now though.


#2

Are you sure this issue is related to PHP 5.4? From the sound of things, you’ve made a bunch of changes here, and it’s hard to tell what might be at fault without knowing a lot more about your site than you’ve told us here.

In particular: Does this behavior go away if you switch to another version of PHP?


#3

Well as per my edit, I realized that the files were saying that they were uploaded/saved to the VPS when using FTP. However, this was not the case. The files were not being uploaded/changed on the site.

I realized this by logging into shell and checking the source code of the files that were affected.

For some reason, it does seem to be gone/fixed/working now, I’m just not sure what caused it or what the issue was (for future reference)


#4

You might have been logged into the wrong userspace. Dev account, etc.


#5

I thought I’d logged into the wrong site aswell, but alas, I was on the right one.

As I said, not sure what happened, could have just been something on my end.