Sendmail not sending in procmail


#1

I have this recipe in my .procmailrc

:0
! my@email.address.com

reading the logs, it looks like sendmail is getting and sending the file

procmail: [18010] Mon Jun 29 16:07:43 2009
procmail: Executing "/usr/sbin/sendmail,-oi,my@email.address.com"
procmail: [18010] Mon Jun 29 16:07:43 2009
procmail: Assigning "LASTFOLDER=/usr/sbin/sendmail -oi my@email.address.com"
procmail: Notified comsat: "dreamhost_ps_login_name@:/usr/sbin/sendmail -oi my@email.address.com"
From myTestAccount@gmail.com Mon Jun 29 16:07:43 2009
Subject: test8
Folder: /usr/sbin/sendmail -oi my@email.address.com 1972

So procmail is getting the message, sendmail is apparently getting the message, but I never receive the message in my inbox.

I tried testing sendmail on the command line

/usr/sbin/sendmail -oi my@email.address.com <testfile

and that worked. I received that email. So what am I missing in my procmail?

Cheers,
Skip


#2

Never mind… sigh

I was testing my procmail script by sending an email to it from my gmail account, and expecting the script to send the email back to the same account. Well, gmail thinks that email is bouncing/ringing, so it won’t let it through. That’s why I wasn’t seeing it. Gmail was stopping it. Sendmail was sending it like it was supposed to.