Secure smtp + thunderbird 3 = not working?


#1

i followed the directions at http://wiki.dreamhost.com/Secure_E-mail

i verified the settings in thunderbird 3, however when i go to send out mail i get a time out error. but i am able to recieve mail. this is set as pop3 in and smtp out.

is there a log file i can check? i looked in the gui and both the error console and activity manager show nothing.


#2

I believe that this is now broken if you can’t overcome a certificate mismatch error. Are you connecting to something like mail.dreamhost.com, or mail.example.com?

-Scott


#3

mail.example.com thunderbird did complain about a certificate mismatch but i accepted it.

edit: i just tryd a telnet and got a prompt, and i paid close attention to thunderbird, it shows “connected to mail.domain.com” but just sits there untill it times out…


#4

i installed wireshark since the logfiles from thunderbird only showed one line for smtp… im not even going to pretend to understand any of this. but when i apply the SMTP filter i get 3 “objects” if im reading it right it seems thunderbird does log in correctly, but beyond that it gets kicked by the server with…

220 homiemail-a14.g.dreamhost.com ESMTP

502 5.5.2 Error: command not recognized

502 5.5.2 Error: command not recognized

502 5.5.2 Error: command not recognized


#5

nothing? really? … guess in the clear with pgp will have to do :: sigh ::


#6

I don’t know if you resolved this but I was having a similar problem. In Thunderbird I could receive emails but not send them through mail.mydomain.com port 587. I could send stuff on my gmail account in Thunderbird using smtp.gmail.com port 587.

I decided to look at my anti-virus software (avast). When I deselected Scan Outbound Mesages everything started to work OK!


#7

Hi there,
I had the same problem. I checked dreamhost’s instructions and it turns out port 587 has optional TLS encryption and port 465 has SSL encryption.

Legacy or not, setting the port to 587 wouldn’t work with my Thunderbird 3.0.4, but port 465 didn’t give me any problem.

So maybe try that, switch the SMTP port to 465 and see if that helps!


#8

Ahh, that seemed to work for me too. Cheers!