Sarge upgrade broke custom PHP and can't recompile

wordpress

#1

The upgrade to Sarge on my server (io) broke the custom php-cgi I was running. This wouldn’t be SO horrible, except that lex seems to be missing on the new OS install, making it impossible to recompile PHP. the configure step dies with:

checking lex output file root… ./configure: line 2422: lex: command not found
configure: error: cannot find output from lex; giving up

Right now my wordpress install runs adequately on the server’s php-cgi, but a lot of my backend stuff was relying on libs and the custom php environment I had.

Has anyone else run into this? Any workarounds?

Update: crontab perms seem to be broken too:

[coj@io: ~]$ crontab -l
crontabs/coj: Permission denied
[coj@io: ~]$ crontab -e
crontabs/coj: Permission denied

This is pretty disappointing.