Rxvt-Unicode Terminfo


#1

I do most of my work from a station running the rxvt-unicode terminal, and when I ssh into your servers I get strange results when typing certain characters, particularly the backspace key. I have run into this situation before, given that rxvt-unicode’s terminfo is not included by default on most Linux distributions, so I am familiar with its effects and how to fix it.

I would like to know, however, if for my convenience you could add it? It would be a huge help and I would greatly appreciate it.


#2

[quote]I would like to know, however, if for my convenience you could add it? It would be a huge help and I would greatly appreciate it.
[/quote]

Hi teratogen2k

Today I had the same problem. In previous occasions, I have been able to correct the problem simply copying the terminfo for rxvt-unicode to .terminfo/r/rxvt-unicode in my home directory. But, for some reason, this does not seem to work anymore. At least Midnight Commander does not accept the info to format the borders with lines instead of weird characters.

‘Chatting’ with a support person didn’t help either. ‘We do not provide support for that’ and two apologies, but no solution.


#3

This isn’t an issue with the terminfo definition — our current systems all already have a terminfo definition for rxvt-unicode (in /lib/terminfo/r/rxvt-unicode). What you’re running into is more likely to be a misbehavior of rxvt-unicode in which it will refuse to accept VT100 line drawing sequences when running in Unicode mode. This is not specific to our servers.

To avoid this bug, try setting your locale to a UTF-8 locale (e.g, LANG=en_US.UTF-8), or use another terminal emulator, such as xterm.


#4

Hi Andrew,

At the moment I have (via ssh at my site in DH):

LANG=en_US.UTF-8

TERM=rxvt-unicode

I have this done in previous machines at Dreamhost, and do this regularly at
the machines in our local network without issues. This is the first time
the trick refuses to work.
[hr]
Ah. The problem is the inverse - mc works normally if LANG = en_US (without UTF-8),
so it seems that the installed mc does not work with UTF-8.

This is a somewhat strange situation - my local system is utf-8, and if I send, eg 'é’
to the ssh connection it appears immediately when LANG = en_US, and a
character delayed if I set UTF-8. Any logic to that?