Running moinmoin at root subdomain

apps

#1

I’m having the darndest time getting MoinMoin to work from this type of url, with cruft-free urls:

http://wiki.example.com/

I can make it work just fine, with cruft-free urls, here:
http://wiki.example.com/w/

I can’t seem to find a way to get apache and the wikiconfig.py to work together properly to make this happen. Has anyone gotten this to work, without needing the subdirectory?

My settings:

.htaccess in /home/user/wiki.example.com directory:


RewriteEngine On
RewriteBase /
RewriteRule ^_static(.)$ htdocs$1
RewriteRule ^w/(.
)$ cgi-bin/moin.fcg/$1 [L]

moin.fcg in /home/user/wiki.example.com/cgi-bin/

class Config(FastCgiConfig):
properties = {‘script_name’: ‘/w’}

I tried a large amount of combinations just trying to remove the ‘w’ as a subdirectory, and just use root. I keep getting either a HTTP 500 error, or the root url “wiki.example.com” show me an apache directory of the files located in /home/user/wiki.example.com

Please help, I’m so stumped!