RubyGems version for Rails

software development

#1

Hi, I am trying to set up a Ruby on Rails (2.3.4) app and got this error when I issued the “rake db:create” command:

Rails requires RubyGems >= 1.3.2 (you have 1.3.1). Please gem update --system and try again.

I saw the article in the support wiki about installing your own copy of RubyGems, but I am confused…Is that something all DreamHost Rails users must do, or is that only for those who need a special configuration of RubyGems?

I assume I missed something, and just wanted to check before installing a local copy of RubyGems.

Thanks.
Phil


#2

Here’s the solution. Took me awhile :slight_smile:

build your application again like this:

rails 2.3.3

This forces the previous version of the rails framework, which IS compatible with RubyGems 1.3.1


#3

That does indeed work! Thanks very much.