Ruby on Rails v1.0

software development

#1

Is there any news on when Rails 1.0 is going to be installed on Dreamhost? It’s been out for several days now.


#2

Nothing that I’ve heard. Contact support and ask, then post your findings here.

-Matttail


#3

Why wait? I’m running 1.0 now. Just freeze_gems on your current app (that will put rails in your vendor/rails folder in your application. Then upload your app to dreamhost.

Or install Ruby, Gems, FCGI, and Rails to your home dir and put that in your path so DH finds your ruby instead of its ruby. With the nature of Rails, I like this approach the best just in case DH moves to a new version that breaks something in production.


#4

I tried doing that. I get this

[20/Dec/2005:09:16:35 :: 19009] Dispatcher failed to catch: uninitialized constant Base (NameError)
…/config/…/vendor/rails/actionpack/lib/…/…/activesupport/lib/active_support/dependencies.rb:195:in const_missing' ../config/../vendor/rails/railties/lib/dispatcher.rb:76:inreset_after_dispatch’
…/config/…/vendor/rails/railties/lib/dispatcher.rb:46:in dispatch' ../config/../vendor/rails/railties/lib/fcgi_handler.rb:141:inprocess_request’
…/config/…/vendor/rails/railties/lib/fcgi_handler.rb:53:in process!' ../config/../vendor/rails/railties/lib/fcgi_handler.rb:52:ineach_cgi’
/usr/lib/ruby/1.8/fcgi.rb:597:in each' /usr/lib/ruby/1.8/fcgi.rb:597:ineach_cgi’
…/config/…/vendor/rails/railties/lib/fcgi_handler.rb:52:in process!' ../config/../vendor/rails/railties/lib/fcgi_handler.rb:22:inprocess!'
dispatch.fcgi:24

I’m running freeze_gems on a windows machine, which really wasn’t what it was designed to do, but it appears to work (I can still run it fine from webbrick).

I get the same error when using dispatch.cgi.


#5

I hope it’s soon. I’m about to launch a project and would prefer to do it on 1.0 and not have to worry about any version issues.