Ruby on Rails timing out... 500 error

software development

#1

Hey guys, I’m getting frustrated now, so I’m wondering if you guys have this problem as well.

I’m currently working on a project in Ruby on Rails. It’s going well so far, but apparently several times a day it just decides to stop working.

Once in a while, I simply can’t start my rails app. I’ll try to view the website and it will just sit, waiting. Then after a couple minutes it’ll give me a 500 error. No dispatch.fcgi processes, no errors in my production.log file.

Any idea why? How can this be fixed? Do you guys have this problem too?

Thanks,

  • Richard

#2

Yes! I’ve been experiencing the exact same thing, and this is what I was going to post to the forum about. It seems very temperamental, some times I can connect to one page, and not others. But for about 4 days I have been experiencing some major problems with my Rails site. Today I haven’t been able to connect to my site at all. The site will try to connect for about 3 minutes and finally end in an ‘Application Error’ after having tried for so long. Nothing showing in the error logs.


#3

Have you read through the wiki yet? There’s quite a bit in there that may help:

http://wiki.dreamhost.com/index.php/Ruby_on_Rails

Also, be aware that you will be running in production mode and need to have that database configured in your database.yml file.

-Tom

-Tom Wilcoxen
convergent arts


#4

It’s fixed now, but I’m not sure exactly what caused the site to have these problems in the first place. Looking in the logs dispatch.fcgi wasn’t being found … I tried chmoding and everything to no avail. In the end I installed a new Rails app, generated new controllers and models for all my site, then uploaded my files overtop, and it works again now.