Ruby on Rails not working?

software development

#1

All of a sudden, my RoR app is not working. I am getting 500 errors.

I have reverted to a version that i know for certain works on DH, and still no luck.

./script/console production works fine. ./script/server -e production works fine and i can use the site with w3m accessing localhost:3000. i have checked my permissions and configuration. FCGI is enabled on the panel

i’m getting FastCGI: comm with (dynamic) server aborts: (first read) idle timeout (120 sec) and FastCGI: incomplete headers (0 bytes) received from server

any ideas?


#2

unbelievable! i copied the RoR app to another domain (with the same panel settings) and it works fine there. it seems to be a problem with a specific machine…

the problematic IP? 208.97.134.91 .


#3

Check out the article here - namely point number 5.


#4

I’ve written up my own DH QuickStart guide at www.HostingRails.com - maybe it’ll help?

Also, be careful about switching versions - that can do some damage.

Rails Hosting - DH supports Ruby on Rails!
[color=#CC0000]Tip - use the DreamHost promo code X50 to get $50 off any of their plans instantly[/color]


#5

I have the same problem. And I’ve done everything that needs to be done. Enabled fast cgi, followed the wiki, all of it. But here’s the other thing. I have my app in cvs, and use a shell script that
simply does a cvs export, and then moves it over to the domain
directory. I exported it using a cvs tag yesterday, and it worked
fine. I redeployed using the exact same tag a little while later, and
now I get the error. I’m guessing it has something to
do with processes running that I am unable to kill, and not configuration. Is there anything
else I can do besides run ‘killall -v dispatch.fcgi’ that will
guarrantee my processes die?