Ruby and Rails


#1

Some Ruby related executables such as rake seem to be missing and gem gives me this message:

/usr/local/lib/site_ruby/1.8/rubygems.rb:1:in require': no such file to load -- rbconfig (LoadError) from /usr/local/lib/site_ruby/1.8/rubygems.rb:1 from /usr/bin/gem:3:inrequire’
from /usr/bin/gem:3

I used rake a few nights ago with no problems and also used gem about a week ago.


#2

We’re seeing exactly the same thing…not sure why; we’ve already filed a support ticket for this (literally minutes ago).


#3

I’m having problems with a rails hosted site this morning -

entering rails --version at the command line seems to return command not found, and there are no fcgi instances being spawned. Anyone else seeing this problem?


#4

Same here.


#5

Yep, me too. I see the exact same issues. Are you all on crackerjack?


#6

Yup, rails has stopped working for me. I tried to run rake to unfreeze rails, and rake wasn’t found. A quick investigation showed that while ‘locate rake’ listed rake as being at

/usr/lib/ruby/gems/1.8/bin/rake
it was actually at
/usr/lib/ruby/ruby/gems/1.8/bin/rake

what’s that extra ruby doing in the path? I guess the symbolic links for ruby at /usr/bin/ are all dead now, so that’s why irb/rake aren’t working :frowning:

further edit: i’m on scotch, btw.


#7

[quote]Are you all on crackerjack?

[/quote]

Nope, I’m on holt and seeing the same thing.


#8

On gower:

./…/config/boot.rb:7:in require': no such file to load -- pathname (LoadError) from ./../config/boot.rb:7 from ./../config/environment.rb:11:inrequire’
from ./…/config/environment.rb:11
from dispatch.cgi:3:in `require’
from dispatch.cgi:3

[gower]$ rails --version
-bash: rails: command not found
[gower]$ ruby -v
ruby 1.8.2 (2005-04-11) [i386-linux]


#9

Same on Hillhurst


#10

Yep, exactly the same problem here on Rollo. Looks as though Ruby is stuffed.

Frustrating considering our site has been down for over 2 hours and no response from Support. I guess a lot of other people must be experiencing the same issues.


#11

yes, same on melrose : my 2 rails powered sites are totally dead and rails --version --> command not found…


#12

Same here, on boyd. Rails and Rake are both missing, while “ruby script/console” returns a ‘require’ error and my dispatch.fcgi’s are timing out.


#13

same on admiralty. hopefully this’ll get fixed soon.


#14

even my site is down, it happened 8-9 hour ago, after showing my site for a presentation . suddenly site response failed with rails error.

as usual i shelled to server and killed my dispatch.fcgi, but they did no start back.

could not run console, or deploy from remote(*as it requires some components from my remote site)

Have posted a sitewide error, which got this reply,

Outage resolved: No server-wide problem was found.
(2006-05-19 02:53:37 PDT, 0 secs ago)
Outage first reported.
(2006-05-19 02:31:21 PDT, 22 mins 16 secs ago)

have tested with freezing my rails.

even tried modifications for config/boot.rb ,

have checked ruby folder, gem folders, also error location

no luck yet.

hope the outage is fixed soon, dont want to waste my weekend watching movies

regards
Senthilnayagam

http://senthilnayagam.com/


#15

Someone probably deployed across machines and got a path wrong in a script, thus breaking everything with the duplicate /ruby/ruby


#16

I do find the lack of feedback from Dreamhost on this (and similar issues) a bit frustrating. Isn’t this supposed to be what dreamhoststatus.com is for?

Coming after the recent downtime due to the unannounced switch to Rails 1.1, this is going to be difficult to explain to clients. Can’t say I’d recommend Dreamhost as a place to host rails sites given the experience of the last few months.


#17

We first noticed the problem a bit after 9PM Thursday on alondra.

Symptoms are as follows:

I can’t run ‘ruby script/console’ without getting:

./script/…/config/boot.rb:6:in require': no such file to load -- pathname (LoadError) from ./script/../config/boot.rb:6 from script/console:2:inrequire’
from script/console:2

Even when I go find the ‘rake’ that’s on the weird path at
’/usr/lib/ruby/ruby/gems/1.8/bin/rake’ it blows up with:

/usr/local/lib/site_ruby/1.8/rubygems.rb:1:in require': no such file to load -- rbconfig (LoadError) from /usr/local/lib/site_ruby/1.8/rubygems.rb:1 from /usr/lib/ruby/ruby/gems/1.8/bin/rake:9:inrequire’
from /usr/lib/ruby/ruby/gems/1.8/bin/rake:9

And finally my Rails web application does run. When I try to manually
run its dispatch.fcgi in ~/lentigen_web_site/public/dispatch.fcgi I
get (unsurprisingly in light of the above)…

./…/config/boot.rb:6:in require': no such file to load -- pathname (LoadError) from ./../config/boot.rb:6 from ./../config/environment.rb:8:inrequire’
from ./…/config/environment.rb:8
from ./dispatch.fcgi:21:in `require’
from ./dispatch.fcgi:21

The weird double ‘…/ruby/ruby/…’ in that one path, plus a broken symlink make me think that perhaps someone ran a script from somewhere they weren’t supposed to…

I hope this is fixed soon. We were supposed to demo a system to a customer this morning on our staging machine, and they just signed up for a Strictly Business account at our recommendation a few days ago. We’re about a week from wanting to go live on that machine, but at the moment nothing works and it’s been 12 hours with no indication that anybody’s aware of or working on the problem… :frowning:


#18

Hello folks,

Here’s a workaround…

export PATH="/usr/local/lib/ruby/ruby/gems/1.8/bin:$PATH"
export RUBYLIB="/usr/local/lib/ruby/ruby/1.8:/usr/local/lib/ruby/ruby/1.8/i386-linux"
export GEM_HOME="/usr/local/lib/ruby/ruby/gems/1.8"

For Rails, you can prepend the following to your config/boot.rb:

stuff = %w(/usr/local/lib/ruby/ruby/1.8 /usr/local/lib/ruby/ruby/1.8/i386-linux)

$LOAD_PATH.unshift stuff[0]
$LOAD_PATH.unshift stuff[1]

ENV[“RUBYLIB”] = stuff.join(":") # Needed for script/console
ENV[“GEM_HOME”] = “/usr/local/lib/ruby/ruby/gems/1.8”


#19

Thanks for the effort! What really needs to happen though is a re-deploy that fixes the last one’s path screwup.


#20

Thanks. Yeah, I wonder why it’s taking so long. Being a relatively new DreamHost customer this breakage (and some other issues) make me a bit angry.