Ruby 1.9.1, Rails 3.0


#1

I used RVM to setup Ruby 1.9.1 in my dreamhost account and then installed Ruby 3. Question is how do I get dreamhost to use the correct ruby version when loading my webpage?

Cheers.


#2

I have also been trying to get Ruby 1.9.1 and Rails 3.0.0.beta4 working with no luck for the past week. Does anyone know how to get a rails 3 app working on Dreamhost? Capistrano fails with a runtime error when I try to run ‘cap deploy:cold’ so I have to manually copy my rails project. When I try to load the application Passenger gives me this error ‘no such file to load – bundler’. I have tried to follow the instructions in the Dreamhost wiki without any success. I have never deployed a rails application before and I am totally lost. Can someone please help before I waste another week on this.


#3

if you’ve never deployed a rails app before, maybe installing ruby 1.9 shouldn’t be the first step.

i found some instructions for rails 3 on ruby 1.8.7:
http://blog.joeygeiger.com/2010/02/08/rails-3-bundler-git-and-dreamhost/
http://blog.joeygeiger.com/2010/05/17/i-beat-dreamhost-how-to-really-get-rails-3-bundler-and-dreamhost-working/
(but someone says in the comments that bundler didn’t install on a shared server because the task was killed)

i haven’t tried this yet.

at least on my server, rubygems has already been updated to 1.3.6. so that should make it easier.

stackoverflow thread: http://stackoverflow.com/questions/2250247/rails-3-on-dreamhost


#4

Thanks for the help but I still cannot get anything to work. It is probably because I am on a shared server. Passenger still cannot find bundler. If Dreamhost will be installing Rails 3 not too far in the future then maybe I can wait since I am still developing the app.


#5

My applications requre Ruby 1.9.1
I’ve tried to install it locally in my VPS but I cannot make it work with the webserver.
Any idea?
I have it installed under my profile, I can put it on PATH first, but only works on the SSH cliente, NOT on the web.

How do I tell the web to pick up a diferent location for Rubuy?

Thanks