Rss


#1

I am having a problem getting the RSS to work on my site with Dreamhost. I’m using the same PHP and .hta as with my other hosting sites with no luck. Do you have any ideas? What does your .htaccess file look like?

Thanks


#2

There are several things that could be the cause of the problem. What is the url of your website? Are you trying to display the contents of RSS feeds on your site? Does the script that you are using rely upon allow_url_fopen to grab the feeds? What error messages, if any, are you receiving?

It’s really hard to guess what may be happening without more information. :wink:

–rlparker


#3

No I don’t have allow_url_fopen. This is an example of the Rss.

the hta is, AddType application/x-httpd-php .php .html .htm

<?php $olderror_reporting =error_reporting(0); include ("http://www.crescent-beach.com/RSSCB2.5/rss.php?url=http://ezinearticles.com/rss/Real-Estate-Condominiums.xml&newpage=1&chead=1&atl=&desc=1&owncss=&eleminate=&auth=&dts=&width=475&max=5&maxfrom=2&maxto=3&tlen=0&rnd=1&bt=0&bs=Double&nmb=1&ntb=1&naf=1&nst=1&nwd=0&nht=0&initime=1200562307&dlttime=0&dlen=0&bg=#FFFFFF&bc=#FFFFFF&tc=BLACK&ts=10&spc=&ims=&lc=BLUE&lstyle=3&rel=1&tfont=Verdana,+Arial,+Sans-serif&rf=".$HTTP_SERVER_VARS['SERVER_NAME'].$HTTP_SERVER_VARS['PHP_SELF']."&phpout=1"); error_reporting($olderror_reporting); ?>

#4

Actually, the disabling of allow_url_fopen / allow_url_include (url fopen wrappers)is what is causing your problem (see the linked text, below “example 2”), as your code snippet is trying to include the remote file via http to a url.

You threw me a little with your reference to .hta, but now I see that you were referring to an .htaccess file (very different thing :wink: ).

At any rate, you will not be able to use your existing code on DreamHost with the default PHP4 or PHP5 installations.

The DH wiki provides information on how to compile and use your own PHP instance, or use DH’s php with your own php.ini file, should you want to re-enable allow_url_fopen, but I strongly advise you do not do this, as it introduces a significant security risk to your site and your server.

The best way to deal with your issue is to use cURL to recode that bit in your script. :wink:

–rlparker


#5

Thank you I really appreciate your help.


#6

You are welcome, and good luck with your site! :slight_smile:

–rlparker