RoundCube WebMail?

apps

#1

Hi,

I stumbled upon this web based mail program that’s much easier on the eyes than SquirrelMail is:

http://roundcube.net/

Has anyone installed this? Is there a process for suggesting a “one click install” candidate?

Thanks,
George


#2

Panel > Home > Sigguestions

-Matttail


#3

I found it a few days ago and am going to look about installing it this weekend.

I would love it for DH to consider dumping Squirrelmail and replacing it with this. RoundCube is also free and open source so it seems like a perfect fit.

bryan | website


#4

It looks pretty nice, but it’s still in alpha and was only released a month and a half ago. I’d be interested in hearing how it works out for you after you install it, but it’s probably a bit early to start asking for one-click installs.


If you want useful replies, ask smart questions.


#5

I absolutely agree, it’s too early to replace it or add it as an install.

I did install it and it works just fine however being a 0.1 alpha release there’s still alot of UI bugs in there but I can absolutely see this thing has a TON of potential and as I said earlier, DH should definitely keep their eyes on this as a possible SquirrelMail replacement in the future.

bryan | website


#6

BTW you can vote for the suggestion now.

bryan | website


#7

Rather than voting to replace SquirrelMail with RoundCube or Hula or Horde/IMP or Zimbra or whatever webmail client you like, I think we need a suggestion that DreamHost offers an alternative to SquirrelMail, but continues to offer SquirrelMail. There are too many people who really like SquirrelMail, hideous as it is, and it would probably be a bad business decision for DH to simply replace it.

-Nancy (kind of a Horde/IMP fan myself)

Infinite Ink ~ http://www.ii.com
Deflexion & Reflexion ~ http://deflexion.com


#8

I just installed it. It looks nice but :

  1. I keep an error above any page :
    Warning: Call-time pass-by-reference has been deprecated - argument passed by value; If you would like to pass it by reference, modify the declaration of iil_C_CountMessages(). If you would like to enable call-time pass-by-reference, you can set allow_call_time_pass_reference to true in your INI file. However, future versions may not support this any longer. in /path/to/roundcube/program/lib/imap.inc on line 843
    Somebody can help ?

  2. I want to see how the project evolves, it’s very young.


#9

It is currently not compatible with PHP 5 so you’ll want to put it in a subdomain with PHP 4 if that’s what you’re running which can cause the error.

bryan | website


#10

There was a new build of RoundCube that was released that fixes a ton of bugs and it’s now compatible with PHP5

bryan | website


#11

Yeah, the new version is pretty great, and fixes some big usability issues. Also, there is an active development mailing list so they’re really working on it and improving it daily. I’d recommend people take a look, bearing in mind it’s alpha.


#12

Yep I’ve been using it exclusively instead of SquirrelMail since 10/8 and this version is much improved. Still a few issues but definitely usable now for the average person.

It really is beautiful and has a great UI. I can’t wait to see what else comes of it.

bryan | website


#13

Hi,

Does anyone have a step-by-step for installing on a DH server? It looked like there was some db stuff involved?
Thanks,
gcs


#14

I would also be interested in learning how to install roundcube or Zimbra or someother webmail app other than squirrel mail on my shared-hosting plan. Any tips would be appreciated.


#15

I installed roundcube on my account and it seems to work. However i can’t login. I tried every combination of username and password (with and without the domainname, the mbox-number etc). Anybody knows which login should be used?


#16

Hi,
What had to be done for the database related part of the install?
Thanks,
George


#17

I’m getting errors saying it can’t find various config/include files. I’m still learning PHP/Apache, and can’t figure this out. Any tips on getting around this? Thanks.


#18

For people needing help installing Roundcube, try this blog article.

bryan | website


#19

Did you ever sort out the proper login credentials? I am at the same point – installed the newest alpha release, my db is up and running, but no login.

I have tried email account name, full email address, my mailbox login (dh-assigned), mailbox-login@domain.com.

for those of you who are up and running, do you think this is an SMTP authorization problem? a port problem? (I have tried 25 and 587).


#20

Today I tried to upgrade to the latest build (20051021) and I ran into this problem too. I had to copy and paste some lines that were in the older build to get it to work.

Open up the index.php file and paste this after line 47:

[code]$CURRENT_PATH=dirname($_SERVER[‘SCRIPT_FILENAME’]);

if ($CURRENT_PATH!=’’)
$CURRENT_PATH.=’/’;
[/code]And then, replace this line:

ini_set('include_path', $INSTALL_PATH.PATH_SEPARATOR.$CURRENT_PATH.'program'.PATH_SEPARATOR.$CURRENT_PATH.'program/lib'.PATH_SEPARATOR.ini_get('include_path')); with

ini_set('include_path', ini_get('include_path').PATH_SEPARATOR.$INSTALL_PATH.PATH_SEPARATOR.'program'.PATH_SEPARATOR.'program/lib');